Bug 1005781 - qemu-kvm cannot open disk images created in ovirt
qemu-kvm cannot open disk images created in ovirt
Status: CLOSED DUPLICATE of bug 964359
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Linux
unspecified Severity unspecified
: rc
: 6.4
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 07:59 EDT by Arik
Modified: 2013-09-09 09:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 09:42:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arik 2013-09-09 07:59:41 EDT
Description of problem:
After updating libvirt to 0.10.2-23 on rhel 6, I wasn't able to run VMs which were created using ovirt. The error that appeared in qemu log was:
qemu-kvm: -drive file=... :could not open disk image ...:Permission denied.

The disk image was created as usual with user vdsm, group kvm and permissions 660. it worked after changing the disks permissions to 667 so I guess that qemu-kvm was running with wrong user/group.

I downgraded to libvirt 0.10.2-18 and now it works again.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create VM using ovirt
2. run the VM on host which is installed with libvirt 0.10.2-23
3.

Actual results:
The VM fails in wait for launch state, because of the error that I mentioned before in the qemu log.

Expected results:
The VM should start.

Additional info:
Comment 2 Eric Blake 2013-09-09 09:42:52 EDT
Fixed in -24.

*** This bug has been marked as a duplicate of bug 964359 ***

Note You need to log in before you can comment on or make changes to this bug.