Bug 1005811 - /tmp/snappy-1.0.4.1-libsnappyjava.so not executable
/tmp/snappy-1.0.4.1-libsnappyjava.so not executable
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
4.8
x86_64 Linux
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 08:38 EDT by ext.gfi.cambier
Modified: 2013-09-10 03:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 03:52:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ext.gfi.cambier 2013-09-09 08:38:08 EDT
Description of problem:
rhq use directory /tmp for /tmp/snappy-1.0.4.1-libsnappyjava.so despite option 
RHQ_CONTROL_ADDITIONAL_JAVA_OPTS=" -Dorg.xerial.snappy.tempdir=~/tmp -Djava.io.tmpdir=~/tmp "
RHQ_STORAGE_INSTALLER_ADDITIONAL_JAVA_OPTS=" -Dorg.xerial.snappy.tempdir=~/tmp -Djava.io.tmpdir=~/tmp "

/tmp is not executable directory


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. unzip RHQ_4.8
2. rhqctl install --storage --storage-config $HOME/storage/storage.properties or rhq-storage-installer.sh --dir ~/rhq-server-4.8.0/rhq-storage --saved-caches ~/storage/saved-caches --commitlog ~/storage/commitlog --data ~/storage/data

Actual results:
11:22:03,791 INFO  [org.jboss.modules] JBoss Modules version 1.2.0.CR1
11:22:03,945 INFO  [org.rhq.server.control.command.Install] Preparing to install RHQ storage node.
Starting RHQ Storage Installer ...
11:22:04,306 INFO  [org.jboss.modules] JBoss Modules version 1.2.0.CR1
11:22:04,398 INFO  [org.rhq.storage.installer.StorageInstaller] Running RHQ Storage Node installer...
11:22:04,414 INFO  [org.rhq.cassandra.Deployer] Unzipping storage node to /appl/jboyxpt1/rhq-server-4.8.0/rhq-storage
11:22:04,749 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to /appl/jboyxpt1/rhq-server-4.8.0/rhq-storage/conf/cassandra.yaml
11:22:04,817 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to /appl/jboyxpt1/rhq-server-4.8.0/rhq-storage/conf/log4j-server.properties
11:22:04,821 INFO  [org.rhq.cassandra.Deployer] Applying configuration changes to /appl/jboyxpt1/rhq-server-4.8.0/rhq-storage/conf/cassandra-env.sh
11:22:04,835 INFO  [org.rhq.cassandra.Deployer] Updating file permissions in /appl/jboyxpt1/rhq-server-4.8.0/rhq-storage/bin
11:22:04,836 INFO  [org.rhq.storage.installer.StorageInstaller] Finished installing RHQ Storage Node.
11:22:04,837 INFO  [org.rhq.storage.installer.StorageInstaller] Updating rhq-server.properties...
11:22:04,852 INFO  [org.rhq.storage.installer.StorageInstaller] Starting RHQ Storage Node
11:22:07,802 ERROR [org.rhq.storage.installer.StorageInstaller] The storage node reported the following errors while trying to start:

java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.xerial.snappy.SnappyLoader.loadNativeLibrary(SnappyLoader.java:312)
        at org.xerial.snappy.SnappyLoader.load(SnappyLoader.java:219)
        at org.xerial.snappy.Snappy.<clinit>(Snappy.java:44)
        at org.apache.cassandra.io.compress.SnappyCompressor.create(SnappyCompressor.java:45)
        at org.apache.cassandra.io.compress.SnappyCompressor.isAvailable(SnappyCompressor.java:55)
        at org.apache.cassandra.io.compress.SnappyCompressor.<clinit>(SnappyCompressor.java:37)
        at org.apache.cassandra.config.CFMetaData.<clinit>(CFMetaData.java:82)
        at org.apache.cassandra.config.KSMetaData.systemKeyspace(KSMetaData.java:81)
        at org.apache.cassandra.config.DatabaseDescriptor.loadYaml(DatabaseDescriptor.java:471)
        at org.apache.cassandra.config.DatabaseDescriptor.<clinit>(DatabaseDescriptor.java:123)
        at org.apache.cassandra.service.CassandraDaemon.setup(CassandraDaemon.java:192)
        at org.apache.cassandra.service.CassandraDaemon.activate(CassandraDaemon.java:411)
        at org.apache.cassandra.service.CassandraDaemon.main(CassandraDaemon.java:454)
Caused by: java.lang.UnsatisfiedLinkError: /tmp/snappy-1.0.4.1-libsnappyjava.so: /tmp/snappy-1.0.4.1-libsnappyjava.so: failed to map segment from shared obje
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
        at java.lang.Runtime.load0(Runtime.java:770)
        at java.lang.System.load(System.java:1003)
        at org.xerial.snappy.SnappyNativeLoader.load(SnappyNativeLoader.java:39)
        ... 17 more



Expected results:


Additional info:


ldd /tmp/snappy-1.0.4.1-libsnappyjava.so
=>         not a dynamic executable

cp /tmp/snappy-1.0.4.1-libsnappyjava.so ~ && ldd ~/snappy-1.0.4.1-libsnappyjava.so
=>      linux-vdso.so.1 =>  (0x00007fff8a5fd000)
        libm.so.6 => /lib64/libm.so.6 (0x00002ba91d646000)
        libc.so.6 => /lib64/libc.so.6 (0x00002ba91d8c9000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003c0ae00000)
Comment 1 ext.gfi.cambier 2013-09-10 03:52:11 EDT
resolu

option JVM_EXTRA_OPTS=" -Dorg.xerial.snappy.tempdir=~/tmp"

Note You need to log in before you can comment on or make changes to this bug.