Bug 100584 - Erroneos IRQ conflicts when loading sb module
Erroneos IRQ conflicts when loading sb module
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 11:55 EDT by Miloš Komarčević
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 20:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (6.72 KB, text/plain)
2003-09-03 14:28 EDT, Miloš Komarčević
no flags Details

  None (edit)
Description Miloš Komarčević 2003-07-23 11:55:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Legacy SB card does not work in Severn because of a reported 
probable IRQ conflict (i.e. sound is chopped). 
However, /proc/interrupts shows there is no IRQ conflict, and
changing the soundcard IRQ does not change the behaviour.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel (w/ or w/o ACPI)
    

Actual Results:  
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
SB 4.13 detected OK (220)
sb: Interrupt test on IRQ7 failed - Probable IRQ conflict

Expected Results:  
No IRQ conflict report and a working soundcard.

Additional info:

$ cat /proc/interrupts
           CPU0
  0:     116001          XT-PIC  timer
  1:       1894          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  usb-uhci, usb-uhci
  7:          0          XT-PIC  soundblaster
  8:          1          XT-PIC  rtc
 11:       3811          XT-PIC  eth0
 12:      76765          XT-PIC  PS/2 Mouse
 14:      13934          XT-PIC  ide0
 15:       1635          XT-PIC  ide1
NMI:          0
ERR:          0
Comment 1 Miloš Komarčević 2003-09-03 14:28:03 EDT
Created attachment 94175 [details]
dmesg output

I've managed to get sb working with 'acpi=off' and reserving
IRQ 5 for legacy ISA in the BIOS.

However, when ACPI is enabled, it uses IRQ 5 as shown in the dmesg
attachment, which creates the conflict with sb.

Note You need to log in before you can comment on or make changes to this bug.