Bug 1005851 - Unable to bypass FQDN requirement for rhevm-setup
Unable to bypass FQDN requirement for rhevm-setup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.5
Assigned To: Alex Lourie
sefi litmanovich
integration
: ZStream
Depends On: 983295
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 09:57 EDT by rhev-integ
Modified: 2013-12-27 10:26 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when installing the manager, the system would not allow installation to proceed unless a fully qualified domain name was specified (FQDN). This caused problems under some conditions, such as if someone was installing it in a lab where an FQDN may not be available. This has now been changed to allow the manager to be installed without specifying an FQDN.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 09:08:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 656653 None None None Never

  None (edit)
Description rhev-integ 2013-09-09 09:57:15 EDT

    
Comment 3 Charlie 2013-11-27 19:43:19 EST
This bug is currently attached to errata RHBA-2013:16431. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 4 Charlie 2013-11-28 19:13:09 EST
Added some document text could some one please check its accuracy?
Thanks.
Comment 5 sefi litmanovich 2013-12-02 04:05:50 EST
Verified on RHEL 6.4 RHEVM3.2.5 SF22. rhevm-setup-3.2.5-0.48.el6ev.noarch

Host fully qualified domain name. Note: this name should be fully resolvable  [sefi.tlv.redhat.com] : 10.35.0.153
10.35.0.153 is an IP address and not a FQDN. A FQDN is needed to be able to generate certificates correctly.
User input failed validation, do you still wish to use it? (yes|no): yes
Comment 7 errata-xmlrpc 2013-12-18 09:08:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1831.html

Note You need to log in before you can comment on or make changes to this bug.