Bug 1005854 - Dual monitor setup isn't working
Dual monitor setup isn't working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 09:59 EDT by Josef Bacik
Modified: 2013-09-10 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 12:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (59.77 KB, text/x-log)
2013-09-09 09:59 EDT, Josef Bacik
no flags Details
dmesg (75.99 KB, text/plain)
2013-09-09 10:00 EDT, Josef Bacik
no flags Details

  None (edit)
Description Josef Bacik 2013-09-09 09:59:07 EDT
Created attachment 795624 [details]
Xorg.0.log

Description of problem:
Bought a shiny new monitor, plugged it in to my second DVI port, box came up and I couldn't see shit.  GDM appeared to be sending something to one of the monitors, but it was just the background.  So I installed lightdm.  Box comes up, viola I can actually see a login prompt, but only on one monitor.  I log in (to gnome3) and I get the same thing that I saw with GDM.  Fine fuck you gnome, I'll use openbox.  Openbox comes up but again it only displays on one monitor.  The second monitor acts like it is getting a signal (the light is green and such) but it is blank.  xrandr acts like it's working

[josef@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 3600 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080      60.0*+
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DVI-1 connected 1680x1050+1920+0 (normal left inverted right x axis y axis) 474mm x 297mm
   1680x1050      60.6*+
   1600x1200      60.0  
   1400x1050      74.9     59.9  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

but it's really not.  DVI-1 is the one that's not outputting anything.  I've tried to force it to wake up by doing things like

xrandr --output DVI-1 --auto --left-of DVI-0

but nothing.  Here is my card

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770 GHz Edition]

here are my versions

Linux localhost.localdomain 3.10.10-200.fc19.x86_64 #1 SMP Thu Aug 29 19:05:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.x86_64
xorg-x11-server-common-1.14.2-9.fc19.x86_64
xorg-x11-server-Xorg-1.14.2-9.fc19.x86_64

I'm attaching my Xorg.0.log.  I'll experiment with different ports and such and see if that makes a difference, but so far just moving the DVI connectors around has just changed which monitor is the one that works.
Comment 1 Josef Bacik 2013-09-09 10:00:26 EDT
Created attachment 795625 [details]
dmesg

Here is my dmesg in case that is needed.
Comment 2 Josef Bacik 2013-09-10 12:16:41 EDT
I should note that each monitor works fine separately, and if I change outputs (like make the other monitor DVI-0) then that one will come up as the main one and the other will be blank.  I tried changing the mode on the one that was not working with

xrandr --output DVI-1 --mode 1600x1200 --right-of DVI-0

but then both monitors flicker and the one that was working comes back with pinstripes and the other one is still blank and I'm forced to reboot the box.
Comment 3 Josef Bacik 2013-09-10 12:29:51 EDT
Fixed with an upstream kernel.

Note You need to log in before you can comment on or make changes to this bug.