This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005865 - Don't check if beah is available for distro when alternative harness is used
Don't check if beah is available for distro when alternative harness is used
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.16.1
: ---
Assigned To: Amit Saha
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 10:19 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 19:54:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Dan Callaghan 2013-09-16 07:17:08 EDT
The reason Beaker checks to make sure the harness repo exists is because Anaconda will complain if we define a repo in the kickstart which is unreachable.

But if the recipe is using an alternate harness Beaker could just skip the harness repo definition, instead of complaining.
Comment 3 Nick Coghlan 2013-11-04 20:56:58 EST
I guess if any alternative harnesses are depending on libraries we currently have in the default harness repos, they should really be providing their own copies rather than relying on the fact beah also needs them.

So +1 for skipping the harnessrepo configuration when the chosen harness is anything other than beah.
Comment 4 Amit Saha 2014-03-13 23:48:10 EDT
http://gerrit.beaker-project.org/#/c/2916/
Comment 5 Amit Saha 2014-03-18 23:26:11 EDT
Getting this into 0.16.1 instead: http://gerrit.beaker-project.org/#/c/2935/
Comment 8 Dan Callaghan 2014-03-26 19:54:24 EDT
Beaker 0.16.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.