Bug 1005895 - Upgrade to f20 fails because of deltarpms
Upgrade to f20 fails because of deltarpms
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
RejectedBlocker
:
: 1017205 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 11:46 EDT by Owen Taylor
Modified: 2013-12-22 00:35 EST (History)
10 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:22:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log with URLGRABBER_DEBUG=1 (58.38 KB, text/plain)
2013-09-09 11:46 EDT, Owen Taylor
no flags Details

  None (edit)
Description Owen Taylor 2013-09-09 11:46:23 EDT
Created attachment 795671 [details]
Log with URLGRABBER_DEBUG=1

When I try to run 

  fedup --network 20 --instrepo http://mirrors.mit.edu/fedora/linux/development/20/x86_64/os/

(or any mirror) I get:

Downloading failed: Errors were encountered while downloading packages.
  rtkit-0.11-6.fc20.x86_64: failure: Packages/r/rtkit-0.11-6.fc20.x86_64.rpm from cmdline-instrepo: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=cmdline-instrepo clean metadata
  ilmbase-1.0.3-7.fc20.x86_64: failure: Packages/i/ilmbase-1.0.3-7.fc20.x86_64.rpm from cmdline-instrepo: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=cmdline-instrepo clean metadata
  highlight-3.15-1.fc20.x86_64: failure: Packages/h/highlight-3.15-1.fc20.x86_64.rpm from cmdline-instrepo: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=cmdline-instrepo clean metadata
  pyliblzma-0.5.3-10.fc20.x86_64: failure: Packages/p/pyliblzma-0.5.3-10.fc20.x86_64.rpm from cmdline-instrepo: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=cmdline-instrepo clean metadata

For those four packages, but no others, instead of the referenced package in the download directory I have a drpm, for example:

 pyliblzma-0.5.3-8.fc19_0.5.3-10.fc20.x86_64.drpm

I'll attach a log run with URLGRABBER_DEBUG=1
Comment 1 Owen Taylor 2013-09-09 11:49:49 EDT
Adding deltarpm=0 to /etc/yum.conf worked around the problem
Comment 2 Will Woods 2013-09-10 14:38:45 EDT
This commit should fix it:

  https://github.com/wgwoods/fedup/commit/625f69f

If someone could apply it (by hand if needed - it's a simple one-line fix) and verify that it fixes the problem that would be mighty helpful.
Comment 3 Matteo Settenvini 2013-09-23 08:33:42 EDT
Thanks Will, I just tried adding that line to download.py, and indeed it fixes the problem.
Comment 4 Adam Williamson 2013-10-18 07:23:19 EDT
As this breaks upgrades with the default configuration and the workaround isn't obvious, it's a major issue. Proposing as a blocker, criterion https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Upgrade_requirements : "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed."
Comment 5 Mike Ruckman 2013-10-21 12:40:26 EDT
Discussed this in 2013-10-21 Blocker Review Meeting [1]. It was agreed to punt as it is not clear whether this is actually a dupe of kparal's [2] and only affects fedup runs with --instrepo, we will discuss this again at the next meeting after kparal has evaluated it

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-21/
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1017205
Comment 6 Kamil Páral 2013-10-22 05:47:26 EDT
*** Bug 1017205 has been marked as a duplicate of this bug. ***
Comment 7 Kamil Páral 2013-10-22 06:22:24 EDT
It seems that this problem does not occur if you don't use --instrepo (it seems that deltarpms are downloaded only from instrepo, not from main repos, for whatever reason).
Comment 8 Adam Williamson 2013-10-23 13:29:49 EDT
Discussed at 2013-10-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-23/f20-blocker-review.2013-10-23-16.00.log.txt . Rejected as a blocker: it now seems clear this doesn't happen unless --instrepo is passed. --instrepo will usually be passed only in special situations and by QA testers before release, not in 'typical' post-release use.
Comment 9 Bruno Medeiros 2013-12-05 18:56:03 EST
Just got a similar problem right now, fedup 0.7.3-4.fc19:

[root@brunojcm-fedora ~]# fedup --network 20 --instrepo http://dl.fedoraproject.org/pub/fedora/linux/development/20/x86_64/os/
setting up repos...
getting boot images...
.treeinfo                                                                                                             | 1.1 kB  00:00:00     
setting up update...
finding updates 100% [======================================================================================================================]
verify local files 100% [===================================================================================================================]
pyliblzma-0.5.3-10.fc20.x86_64.rpm                                                                                    |  46 kB  00:00:00     

Downloading failed: Errors were encountered while downloading packages.
  pyliblzma-0.5.3-10.fc20.x86_64: failure: Packages/p/pyliblzma-0.5.3-10.fc20.x86_64.rpm from cmdline-instrepo: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=cmdline-instrepo clean metadata
Comment 10 Will Woods 2013-12-05 19:02:02 EST
Your log doesn't mention anything about drpms. This is a totally different problem.

This is likely exactly what it says - the file on the server doesn't match the yum metadata. Try 'fedup --clean-metadata' to clear the metadata.
Comment 11 Bruno Medeiros 2013-12-05 19:45:01 EST
I think it's the same problem, because the patch fixed the problem for me. After put 'conf.deltarpm = 0' in the download.py, no more errors during download phase.

After fixing this bug, I'm back to my original issue:
https://bugzilla.redhat.com/show_bug.cgi?id=1038863
Comment 12 Fedora Update System 2013-12-11 17:12:37 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 13 Fedora Update System 2013-12-11 17:20:47 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 14 Fedora Update System 2013-12-11 17:22:37 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 15 Fedora Update System 2013-12-13 00:10:07 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-12-19 02:22:36 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-12-19 20:44:54 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-12-22 00:35:02 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.