Bug 1005914 - Status text note of others does not update when connecting if they changed while connecting user was off line
Status text note of others does not update when connecting if they changed wh...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin-sipe (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stefan Becker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 12:25 EDT by John Griffiths
Modified: 2013-10-12 03:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 03:05:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of buddy list (68.34 KB, image/png)
2013-09-09 13:17 EDT, John Griffiths
no flags Details
debug of pidgin session (913.48 KB, text/x-log)
2013-09-09 14:12 EDT, John Griffiths
no flags Details

  None (edit)
Description John Griffiths 2013-09-09 12:25:20 EDT
Description of problem:
When a user updates their status message text, the status message text does not update.

Version-Release number of selected component (if applicable):
pidgin-sipe-1.16.1-1.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. Log in to a system that uses pidgin-sipe
2. Get someone in your buddy list to change their status text


Actual results:
Nothing happens

Expected results:
Status should reflect the new status and message

Additional info:
Comment 1 Stefan Becker 2013-09-09 13:03:24 EDT
Same rule applies as on upstream bug reports: no --debug log, no fix.

I just tested status text changes on an Office 365 account (on Lync 2013) and OCS2007 account. On both it works as expected.

BTW: if you are not subscribed to a buddy (or the subscription for whatever reason is not working --> hence --debug log) SIPE will not receive any presence updates, including status and status text.
Comment 2 John Griffiths 2013-09-09 13:17:30 EDT
Created attachment 795716 [details]
screen shot of buddy  list

I redacted the personal info of buddies.

The status of the 3rd entry from the bottom, David, "At the MD office" has not changed even though he has changed it.
Comment 3 John Griffiths 2013-09-09 13:18:21 EDT
I have a group that I have several users in. They all display in my buddy list. I would assume that I am subscribed to them.

This is what I captured in the debug window:

(13:07:34) util: Writing file prefs.xml to directory /home/jrg3/.purple
(13:07:34) util: Writing file /home/jrg3/.purple/prefs.xml
(13:08:17) blist: Updating buddy status for sip:brian.dickerson@pae.com (Office Communicator)
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:57) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/y changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/height changed, scheduling save.
(13:08:58) prefs: /pidgin/blist/y changed, scheduling save.
(13:09:02) util: Writing file prefs.xml to directory /home/jrg3/.purple
(13:09:02) util: Writing file /home/jrg3/.purple/prefs.xml
Comment 4 Stefan Becker 2013-09-09 13:21:51 EDT
"run pdigin with --debug" log, not the contents of the debug window [don't blame me, blame the Pidgin guys for this useless debug window]
Comment 5 John Griffiths 2013-09-09 13:33:01 EDT
The status from Away to Available or Do not disturb change. What I am not getting is when a buddy stays Available but changes the text message to something other than it was before. For instance, David changed his from "At the MD office" to "At home office," but the text is not updated on my client in Pidgin but it is for those using Lync.


Will do.
Comment 6 John Griffiths 2013-09-09 14:12:49 EDT
Created attachment 795730 [details]
debug of pidgin session

I sanitized this a bit.
Comment 7 Stefan Becker 2013-09-09 15:02:29 EDT
(In reply to John Griffiths from comment #6)
> Created attachment 795730 [details]
> debug of pidgin session

OK, I see you discussion with Mark and Mark's status changes.

I don't see *any* status updates sent by the server for David after the initial subscription. So it is no wonder you don't see any changes. On the other hand this is not SIPE's fault then either,

I think I know what the problem is: your installation is OCS2007 (or newer). Please make sure that David has not set restricted access in his client. OCS2007 introduced access levels for Personal, Team, Company & Public. If f.ex. you and David are not in the same team and David has set the visibility for access level for "Company" to "status update only", then *YOUR* client will only receive available/busy/offline presence events from the server.

Please refer to <https://sourceforge.net/apps/mediawiki/sipe/index.php?title=Access_Levels> for more details.

I'm inclined to close this as NOTABUG, please report back after checking with your colleague.
Comment 8 John Griffiths 2013-09-09 15:54:51 EDT
David and I are in the same team.

We both have our access level set at Company.

David had his status as "At the MD office" yesterday. When I logged in this morning, he was working from his home. He had changed his status, but the change was not picked up by my client.
Comment 9 Stefan Becker 2013-09-09 22:14:02 EDT
(In reply to John Griffiths from comment #8)
> David had his status as "At the MD office" yesterday. When I logged in this
> morning, he was working from his home. He had changed his status, but the
> change was not picked up by my client.

Your log shows no status updates for buddy "David", therefore SIPE can't update the buddy information. Hence this can't be a SIPE bug.

Unless you can provide a --debug log showing otherwise, I intend to close this as NOTABUG.
Comment 10 John Griffiths 2013-09-09 22:42:39 EDT
You are missing the point.

I was off line when David changed his status. There is no way for my client to receive an update. So, there is no way to provide a debug log for David changing his status since it occurred when I was off line. Not only that, the old status is maintained in Pidgin until David changes his status while I am on line.

When I log into Fedora the next time and Pidgin starts, the old status for David is still shown. SIPE apparently is not interrogating the server for the current status or the sever does not send down the new status when I log in.

I do not know which it is, but apparently Lync clients do not have this problem. So, one is led to believe that it must be a SIPE bug.
Comment 11 Stefan Becker 2013-09-09 23:29:50 EDT
(In reply to John Griffiths from comment #10)
> You are missing the point.

I can only state what I can determine from the information provided by you.


> When I log into Fedora the next time and Pidgin starts, the old status for
> David is still shown.

Presence information is PUSH-based, i.e. SIPE subscibes to a buddy

<batchSub xmlns="http://schemas.microsoft.com/2006/01/sip/batch-subscribe" uri="sip:<account user2@<domain>" name="">
<action name="subscribe" id="63792024">
<adhocList>
...
<resource uri="sip:david.schell@<domain>"/>
...

and after that the server pushes presence information to the client. Your log only shows one such event for that particular buddy, i.e. the initial information provided by the server is:

<categories xmlns="http://schemas.microsoft.com/2006/09/sip/categories" uri="sip:David.Schell@<domain>">
...
<category name="note" instance="0" publishTime="2013-09-04T13:00:25.727">
<note xmlns="http://schemas.microsoft.com/2006/09/sip/note"><body type="personal" uri="">At the MD office</body></note>
</category>
...
</categories>


> SIPE apparently is not interrogating the server for
> the current status or the sever does not send down the new status when I log
> in.

SIPE asked the server for the information and it simply displays the information it receives.


> I do not know which it is, but apparently Lync clients do not have this
> problem. So, one is led to believe that it must be a SIPE bug.

OCS is complex. Here are some points from the top of my head which you could or your IT department could go through:

 - "at MD office": does that mean intranet, i.e. direct connection to internal OCS server?

 - "at home office": does that mean access via VPN (i.e. to the same internal server as at the office) or via publicly visible OCS server?

  - when David is at the MD office: do you see when he changes the note text then?

  - when David is at the home office: do you see when he changes the note text then?

  - if you use the OCS client with your account: what does happen in the previous two cases?

  - what do others using OCS client for those cases?

  - when Mark works from home office, do you still receive status updates?
Comment 12 John Griffiths 2013-09-10 08:12:53 EDT
Sorry for the confusion. Looking back, I did not describe this correctly originally. I will change short description. Can't edit original Description. 

None of us are on the same network as the OCS server.

When David is connected "at MD office," he is on a natted network with access to the Internet.

When David is connected "at home office," he is on his home network which is also a natted network. He may also open a VPN, but it is not to the network with the OCS server. If he opens a VPN, then it will be to the MD office.

The same applies to the rest of the team including me. We are on natted networks either at the MD office or our homes. And, like David, if we open a VPN, then we will be connecting to the MD office and not the network with the OCS server.

When David and I am on line and he changes his note text, I see the change whether he is at the home or MD office.

Mark was working from his home office when I had him change his text note for this testing. I also see the text note change for others working from the MD office if I am on line when they do it.

I only use Pidgin with SIPE. Do not have a Lync client. Others with Windows workstations do use Lync. According to what they tell me, they see the changes correctly even when they are off line when David changes his text status the next time they connect.
Comment 13 John Griffiths 2013-09-10 08:22:39 EDT
(In reply to John Griffiths from comment #0)
> Description of problem:
> When a user updates their status message text, the status message text does
> not update.

This should be:
When a user is off line and another user updates their status note text, the note text is not updated for the off line user when the off line user connects again.

> 
> Version-Release number of selected component (if applicable):
> pidgin-sipe-1.16.1-1.fc19.x86_64
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. Log in to a system that uses pidgin-sipe
> 2. Get someone in your buddy list to change their status text
> 

This should have been:
1. Log out of Pidgin SIPE connection
2. While you are off line, get a buddy to change their status note text but not their status. That is keep "available" as status, just change the note text for the status.
3. Log in to the Pidgin SIPE connection

> 
> Actual results:
> Nothing happens

Should be:
Old status text note for buddy from previous connection is displayed.

> 
> Expected results:
> Status should reflect the new status and message

Should be:
Status note text should reflect the new status note text.

> 
> Additional info:

Sorry for inaccurate original report.
Comment 14 Stefan Becker 2013-09-10 10:04:05 EDT
Thanks for the clarification.

I've now tried the same test case with one of my colleagues and can't reproduce your problem on our OCS2007 installation. After I logged in I saw the new status note text my colleague had set while I was offline.

I have no clue why the OCS server would not update its internal information while you are offline. To be 100% sure that this is not some problem with your account please test this while you are offline with SIPE and online with the OC/Lync client. Use a colleagues Windows machine if you don't have access to one.

But I hope you can agree with me that some misbehaviour on the OCS server side while you are offline with the SIPE client, can't be a bug in the SIPE client.
Comment 15 John Griffiths 2013-09-10 12:16:19 EDT
I will give this a try. Since I work remotely, I will have to install Lync on a local machine. This may take a bit. I rarely use Windows.

I do agree that if this is an issue with the OCS server side, it is not a SIPE client issue. I would appreciate it if you will leave this open until I can get a client installed and configured.
Comment 16 Stefan Becker 2013-10-11 11:43:26 EDT
It has been a month now and no update yet.

I'm going to close this as NOTABUG if I don't here from you.
Comment 17 John Griffiths 2013-10-11 22:38:20 EDT
Seems to have mostly working recently.


Lync seems to be right all the time. May have been/be a server issue.

Go ahead and close the bug and if I can find a way to reproduce consistently, I'll reopen.

Thanks and sorry for the delay.

Note You need to log in before you can comment on or make changes to this bug.