Bug 1005990 - RFE: Add option to allow creation of a temporary repository to satisfy build dependencies
RFE: Add option to allow creation of a temporary repository to satisfy build ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 15:00 EDT by Richard Shaw
Modified: 2014-05-16 06:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 06:01:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Shaw 2013-09-09 15:00:35 EDT
Description of problem:
In order to chain build packages you currently need to do something like:
mock --init
mock --install <dependencies>
mock --noclean <SRPM>


Expected results:
An option such as "--temprepo  Creates a temporary repository for build dependencies."
which would run createrepo in the specified directory and add it as a repository used to satisfy build dependencies would make this much easier and allow building packages more or less one step instead of the 3 above.

Not to mention if you forget to add --no-clean you have to start all over.
Comment 1 Richard Shaw 2013-09-09 15:49:39 EDT
It looks like mockchain *ALMOST* fills this need but I'm guessing the -a option want's a true url, not a path:

  File "/bin/mockchain", line 352, in <module>
    main(sys.argv)
  File "/bin/mockchain", line 251, in main
    res, msg =  add_local_repo(my_mock_config, my_mock_config, baseurl)
  File "/bin/mockchain", line 105, in add_local_repo
    repoid=baseurl.split('//')[1].replace('/','_')
IndexError: list index out of range

I tried turning it into a url "file://..." and although mockchain didn't complain, it didn't pull in the newer packages and instead used the regular repo packages.

Also, mockchain seems to lack a --resultdir option...
Comment 2 Miroslav Suchý 2014-05-16 06:01:57 EDT
If you pass several src.rpm to mockchain then mockchain automaticaly create local repo with those packages which were already built. No need to specify -a.

Also if you are not sure in which order it should be build, you can use 'mockchain --recurse' which will try to build failed packages again, if some other packages will succeed.

Note You need to log in before you can comment on or make changes to this bug.