Bug 1006045 - yum-rhn-plugin should keep its higher default timeout
yum-rhn-plugin should keep its higher default timeout
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Herr
Dimitar Yordanov
:
Depends On: 1006037
Blocks: 1082754
  Show dependency treegraph
 
Reported: 2013-09-09 17:15 EDT by Stephen Herr
Modified: 2015-03-05 05:52 EST (History)
3 users (show)

See Also:
Fixed In Version: yum-rhn-plugin-2.0.1-2-el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1006037
Environment:
Last Closed: 2015-03-05 05:52:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2013-09-09 17:15:29 EDT
+++ This bug was initially created as a clone of Bug #1006037 +++

yum-rhn-plugin-1.10.1-1 and higher now accept a timeout parameter from yum instead of implicitly relying on the rhn-client-tools defaults. However, this can lead to less-than-ideal results for some people given that the yum default is 30s and the rhn-client-tools default was 120s.

Let's make yum-rhn-plugin have its own timeout default of 120s. If it is not set then we can fall back to the yum.conf timeout or yum's default if neither are set.

--- Additional comment from Stephen Herr on 2013-09-09 16:32:56 EDT ---

Committing to Spacewalk master:
62b3036b9503d4dbbc9d503275ba06c511c85653
Comment 1 Stephen Herr 2013-09-09 17:16:20 EDT
We should make sure this gets into RHEL 7 as well.
Comment 8 errata-xmlrpc 2015-03-05 05:52:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0473.html

Note You need to log in before you can comment on or make changes to this bug.