Bug 1006057 - eclipse-findbugs fails to run
eclipse-findbugs fails to run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-findbugs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 18:21 EDT by Omair Majid
Modified: 2013-11-25 23:04 EST (History)
2 users (show)

See Also:
Fixed In Version: jsr-305-0-0.16.20130910svn.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 23:04:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omair Majid 2013-09-09 18:21:02 EDT
Description of problem:
Running findbugs from within eclipse ends with an internal error:

An internal error occurred during: "Finding bugs in xdg-java...".
Attempted to beginRule: P/xdg-java, does not match outer scope rule: MutexSchedulingRule, project: P/xdg-java

Version-Release number of selected component (if applicable):
eclipse-platform-4.3.0-4.fc19.x86_64
eclipse-jdt-4.3.0-4.fc19.x86_64
eclipse-findbugs-1.3.9-8.fc19.noarch


How reproducible:
Every time.

Steps to Reproduce:
1. Create a new empty java project in eclipse. Call it "hello-world"
2. Add a new class named HelloWorld to the project
3. Run findbugs on that class.

Actual results:
Error.

Expected results:
Findbugs works.

Additional info:
Comment 1 Richard Fearn 2013-09-10 13:14:27 EDT
There's a stack trace in the Error Log:

java.lang.IllegalArgumentException: Attempted to beginRule: P/hello-world, does not match outer scope rule: MutexSchedulingRule, project: P/hello-world
	at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
	at org.eclipse.core.internal.jobs.ThreadJob.illegalPush(ThreadJob.java:134)
	at org.eclipse.core.internal.jobs.ThreadJob.push(ThreadJob.java:333)
	at org.eclipse.core.internal.jobs.ImplicitJobs.begin(ImplicitJobs.java:85)
	at org.eclipse.core.internal.jobs.JobManager.beginRule(JobManager.java:286)
	at org.eclipse.core.internal.resources.WorkManager.checkIn(WorkManager.java:118)
	at org.eclipse.core.internal.resources.Workspace.prepareOperation(Workspace.java:2283)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2340)
	at de.tobject.findbugs.reporter.MarkerUtil.createMarkers(MarkerUtil.java:118)
	at de.tobject.findbugs.builder.FindBugsWorker.updateBugCollection(FindBugsWorker.java:312)
	at de.tobject.findbugs.builder.FindBugsWorker.work(FindBugsWorker.java:190)
	at de.tobject.findbugs.actions.FindBugsAction$StartedFromViewJob.runWithProgress(FindBugsAction.java:248)
	at de.tobject.findbugs.FindBugsJob.run(FindBugsJob.java:61)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
Comment 2 Richard Fearn 2013-09-10 13:25:54 EDT
Looks like this bug: http://sourceforge.net/p/findbugs/bugs/1121/

These commits could be useful for backporting a fix:

http://code.google.com/p/findbugs/source/detail?r=14435
http://code.google.com/p/findbugs/source/detail?r=14495

I'm also looking at upgrading FindBugs in Fedora to 2.0.2 (see #790762), which would also fix this.
Comment 3 Omair Majid 2013-09-10 13:28:00 EDT
(In reply to Richard Fearn from comment #2)
> I'm also looking at upgrading FindBugs in Fedora to 2.0.2 (see #790762),
> which would also fix this.

Thanks!
Comment 4 Fedora Update System 2013-10-27 07:46:07 EDT
jsr-305-0-0.16.20130910svn.fc19,jFormatString-0-0.11.20111215svn.fc19,findbugs-contrib-4.6.1-5.fc19,findbugs-bcel-5.3-0.1.20130910svn1521566.fc19,findbugs-2.0.2-2.fc19,eclipse-findbugs-2.0.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jsr-305-0-0.16.20130910svn.fc19,jFormatString-0-0.11.20111215svn.fc19,findbugs-contrib-4.6.1-5.fc19,findbugs-bcel-5.3-0.1.20130910svn1521566.fc19,findbugs-2.0.2-2.fc19,eclipse-findbugs-2.0.2-1.fc19
Comment 5 Fedora Update System 2013-10-27 07:51:18 EDT
eclipse-findbugs-2.0.2-1.fc20,findbugs-2.0.2-2.fc20,findbugs-bcel-5.3-0.1.20130910svn1521566.fc20,findbugs-contrib-4.6.1-5.fc20,jFormatString-0-0.11.20111215svn.fc20,jsr-305-0-0.16.20130910svn.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/eclipse-findbugs-2.0.2-1.fc20,findbugs-2.0.2-2.fc20,findbugs-bcel-5.3-0.1.20130910svn1521566.fc20,findbugs-contrib-4.6.1-5.fc20,jFormatString-0-0.11.20111215svn.fc20,jsr-305-0-0.16.20130910svn.fc20
Comment 6 Fedora Update System 2013-10-28 23:44:43 EDT
Package jsr-305-0-0.16.20130910svn.fc19, jFormatString-0-0.11.20111215svn.fc19, findbugs-contrib-4.6.1-5.fc19, findbugs-bcel-5.3-0.1.20130910svn1521566.fc19, findbugs-2.0.2-2.fc19, eclipse-findbugs-2.0.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jsr-305-0-0.16.20130910svn.fc19 jFormatString-0-0.11.20111215svn.fc19 findbugs-contrib-4.6.1-5.fc19 findbugs-bcel-5.3-0.1.20130910svn1521566.fc19 findbugs-2.0.2-2.fc19 eclipse-findbugs-2.0.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20181/jsr-305-0-0.16.20130910svn.fc19,jFormatString-0-0.11.20111215svn.fc19,findbugs-contrib-4.6.1-5.fc19,findbugs-bcel-5.3-0.1.20130910svn1521566.fc19,findbugs-2.0.2-2.fc19,eclipse-findbugs-2.0.2-1.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-23 22:39:24 EST
eclipse-findbugs-2.0.2-1.fc20, findbugs-2.0.2-2.fc20, findbugs-bcel-5.3-0.1.20130910svn1521566.fc20, findbugs-contrib-4.6.1-5.fc20, jFormatString-0-0.11.20111215svn.fc20, jsr-305-0-0.16.20130910svn.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-25 23:04:10 EST
jsr-305-0-0.16.20130910svn.fc19, jFormatString-0-0.11.20111215svn.fc19, findbugs-contrib-4.6.1-5.fc19, findbugs-bcel-5.3-0.1.20130910svn1521566.fc19, findbugs-2.0.2-2.fc19, eclipse-findbugs-2.0.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.