Bug 1006089 - Business User getting started guide & Developer getting started guide
Business User getting started guide & Developer getting started guide
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vikram Goyal
Marek Baluch
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 21:48 EDT by Catherine Robson
Modified: 2014-12-17 22:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-17 22:27:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Catherine Robson 2013-09-09 21:48:17 EDT
Description of problem:
Since the use cases and needs of these two main user groups (Business Users and Developers) of the BPM Suite product are so different, it is hard for a getting started guide to stay concise and clear if it is trying to provide information to both parties

Suggested solution:
Suggest that we move to having two different documents for 6.0 GA with roughly the following content.

Getting Started for Developers
1. Downloading
2. Installation (JBDS, Tools, Central, Dashbuilder)
3. Configuration (Maven, etc)
4. Run (start apps)
5. (optional) Learn the Product (Hello World)

Getting Started for Business Users
1. Downloading
2. Installation
3. Verify Installation (Start apps)
4. (Optional) Learn the Product (Hello world)
4.1 Navigate business central
4.1 Create a process (shows process, rule, form)
4.2 Deploy and Execute
4.3 Work with Tasks
4.3 View Business Activity Monitoring (BAM)
Comment 2 Prakash Aradhya 2013-10-02 14:49:57 EDT
Vikram, 
It would be really nice to get this done targeting different users.

Please feel free to work with Eric Schabell and UX team.
I will be happy to review and provide feedback. 

Essentially we should keep it as simple as possible for business users.
Comment 3 Vikram Goyal 2013-10-02 18:25:26 EDT
Sounds good. I am happy to produce the two separate docs targeting different users for GA (and not beta).
Comment 5 Vikram Goyal 2014-12-17 22:27:51 EST
Not sure if there is still a need for this. Closing this bug. If you think this still requires doing then please reopen.

Note You need to log in before you can comment on or make changes to this bug.