Bug 10061 - disk partitioning
Summary: disk partitioning
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-08 15:28 UTC by Sergey
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 11:49:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergey 2000-03-08 15:28:40 UTC
I used graphical redhat installation,
when partitioning my HDD I noticed the following bugs,

1) I created several ( probably 10 ) ext2 and fat partitions ,
 then I changed my mind, deleted all partitions,
 then created two partitions, but  they were named /dev/hda11 and
/dev/hda12 instead of /dev/hda1 and /dev/hda2.
 again I deleted all partitions and created one - it was named /dev/hda11
I didn't proceed with installation , just rebooted.


2) Such a situation :
 I create new ext2 partition, it becomes /dev/hda7, then
 I create another ext2 partition , but :  the first partition becomes
/dev/hda8 and the new second partition becomes /dev/hda7

 I don't exactly remember mount points , but probably they were / and
/home.( sizes ~1,5Gb and ~300Mb accordingly)
 I didn't proceed with installation , just used Partition Magic.


3) No any warning displayed when I created partition with mount point
/boot  far beyond the 8,4 Gb limit.

Comment 1 Michael Fulbright 2000-03-08 17:38:59 UTC
I tried testing these issues against the latest internal (rawhide) release:

1) I could not reproduce problem number 1 on a system with a single drive in
   which I created 12 partitions in disk druid, then deleted them all, then
   started creating new partitions. The new partitions were numbered
as             expected.

2) In disk druid the partitions are allocated based on several weights. For
   example, /boot will try to be allocated before /opt.  It is normal for the
   partitions you create to change number. The pre-existing partitions will not
   change their number, as expected.

3) When you create /boot with disk druid it enforces the 1024 cylinder limit (as
   well as forcing /boot to be on one of the first two drives).  Did the /boot
   you used previously exist and you assigned it to /boot in disk druid? That
   would be the only case where I could see that happening.

Comment 2 Jay Turner 2000-04-24 11:49:59 UTC
All of these issues were addressed and resolved in the 6.2 Red Hat Linux
installation program.

Comment 3 Jay Turner 2000-04-24 11:50:59 UTC
Actually, just to clarify, 1 and 3 were addressed and resolved.  Issue 2 is how
Disk Druid is supposed to behave, just as msf responded.


Note You need to log in before you can comment on or make changes to this bug.