Bug 100610 - adsl-connect dies after reboot after unclean system shutdown
Summary: adsl-connect dies after reboot after unclean system shutdown
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 17:44 UTC by feily
Modified: 2015-01-08 00:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 11:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:268 normal SHIPPED_LIVE Updated rp-pppoe package fixes invalid idle parameter 2004-09-01 04:00:00 UTC

Description feily 2003-07-23 17:44:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322; .NET CLR 1.0.3705)

Description of problem:
When the system boots up again after it crashed for example after a power 
failure, adsl-connect establishes the adsl connection as expected and then 
exits. So if the adsl connection dies, it will not be reconnected

Version-Release number of selected component (if applicable):
rp-pppoe-3.5-2

How reproducible:
Always

Steps to Reproduce:
1. Create an adsl connection with adsl-setup which comes up at boot time and 
connect it with ifup pppX
2. Turn off the system by pressing the power button
3. Turn it on again and wait until it boots up
    

Actual Results:  adsl-connect is not running

Expected Results:  adsl-connect should be running

Additional info:

Comment 1 Claudio 2003-07-28 22:36:35 UTC
hi,
it's ok that after an unclean reboot the connetion don't start, because the
ISP's routers take 10 minutes to understand that you are not connected.
The question is that also a correct reboot or shutdown break the connection for
me  and i must stop the adsl connection before to restart the system.
With RH 8 i don't have this problem.

sorry for my poor english.

Claudio

Comment 2 Ngo Than 2003-08-12 12:31:32 UTC
does this problem still appear if you create an adsl connection with
redhat-config-network?

Comment 3 Ngo Than 2004-03-04 11:47:34 UTC
it looks like that adsl-connect does not handle the alias name
correctly. This problem is fixed in rp-pppoe-3.5-11.

Comment 4 Jay Turner 2004-09-02 02:34:06 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-268.html



Note You need to log in before you can comment on or make changes to this bug.