Bug 1006113 - anaconda unable to get update image
anaconda unable to get update image
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-09 23:50 EDT by lnie
Modified: 2013-09-16 11:28 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 11:28:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (2.36 KB, text/x-log)
2013-09-09 23:57 EDT, lnie
no flags Details
syslog (61.49 KB, text/plain)
2013-09-09 23:58 EDT, lnie
no flags Details
program.log (9.37 KB, text/x-log)
2013-09-09 23:58 EDT, lnie
no flags Details
packaging.log (11.90 KB, text/x-log)
2013-09-09 23:59 EDT, lnie
no flags Details
screen (20.05 KB, image/png)
2013-09-10 01:42 EDT, lnie
no flags Details

  None (edit)
Description lnie 2013-09-09 23:50:29 EDT
Description of problem:
Do an install with "inst.updates=http://.../updates.img",
anaconda doesn't prepare the updates.img and copy its content to /tmp/updates

Version-Release number of selected component (if applicable):
F20 Alpha TC5 (x86_64)

How reproducible:
always

Steps to Reproduce:
1.Do an install with "inst.updates=http://.../updates.img",
2 When anaconda enter into the first install screen,Sent"Alt+F2" and cd into /tmp
3.As shown in the attachment,there is no updates

Actual results:


Expected results:


Additional info:
Comment 1 lnie 2013-09-09 23:57:29 EDT
Created attachment 795814 [details]
anaconda.log
Comment 2 lnie 2013-09-09 23:58:13 EDT
Created attachment 795815 [details]
syslog
Comment 3 lnie 2013-09-09 23:58:51 EDT
Created attachment 795816 [details]
program.log
Comment 4 lnie 2013-09-09 23:59:28 EDT
Created attachment 795817 [details]
packaging.log
Comment 5 lnie 2013-09-10 01:42:16 EDT
Created attachment 795826 [details]
screen
Comment 6 Tim Flink 2013-09-11 19:47:52 EDT
which updates.img did you use? the one listed in the testcase? I don't think that's a valid updates.img anymore.

When I use one built earlier today, it works for my testing:
http://dlehman.fedorapeople.org/updates/updates-997690.0.img
Comment 7 Tim Flink 2013-09-11 19:49:19 EDT
If this is a valid bug, it's probably a blocker. Proposing as a blocker for F20 alpha due to violation of the following F20 alpha release criterion [1]:

The installer must be able to download and use an installer update image from an HTTP server.

[1] http://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Update_image
Comment 8 lnie 2013-09-11 22:37:09 EDT
(In reply to Tim Flink from comment #6)
> which updates.img did you use? the one listed in the testcase? I don't think
> that's a valid updates.img anymore.
> 
> When I use one built earlier today, it works for my testing:
> http://dlehman.fedorapeople.org/updates/updates-997690.0.img

yes,the testcase one.I'm able to download it manually.what's more,I have asked others to test this with the testcase one,there is no this bug? in i386 install.hmmm,I feel a little confused now.
Comment 9 lnie 2013-09-12 00:30:36 EDT
I have tested this case with the image you offered,and asked that one to test this case again.It turns out that you are right.BTW,I think it's necessary to update the image in that testcase,yes? :(
Comment 10 Tim Flink 2013-09-12 00:43:41 EDT
(In reply to lnie from comment #9)
> I have tested this case with the image you offered,and asked that one to
> test this case again.It turns out that you are right.BTW,I think it's
> necessary to update the image in that testcase,yes? :(

The updates.img in that testcase just 3 years old and the updates.img format has changed quite a bit since then.

I agree that we should probably update that updates.img, though
Comment 11 David Shea 2013-09-12 09:46:52 EDT
updates.img is unpacked to /run/install/updates
Comment 12 Petr Schindler 2013-09-16 11:28:03 EDT
It was caused by outdated test case (updates.img used there was too old).

Note You need to log in before you can comment on or make changes to this bug.