Bug 1006149 - ignores /.autorelabel silently
ignores /.autorelabel silently
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-10 02:35 EDT by Björn "besser82" Esser
Modified: 2013-09-10 04:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 04:26:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn "besser82" Esser 2013-09-10 02:35:39 EDT
Description of problem:

  When touching /.autorelabel && reboot, there's actually no relabeling
  of the selinux-contexts started.  /.autorelabel is purged and nothing
  happens, but a "regular" start-up.


Version-Release number of selected component (if applicable):

  selinux-policy-3.12.1-75.fc20.noarch


How reproducible:

  100%


Steps to Reproduce:

  1. `sudo touch /.autorelabel`
  2.  reboot system


Actual results:

  the presence of /.autorelabel is ignored, the file is purged and just
  a "regular" start is done.


Expected results:

  the presence of /.autorelabel should trigger the relabeling of the
  selinux-contexts on fs, like it is the way in <= F19.


Additional information:

  this happens on a fresh install of F20 TC5 x86_64
Comment 1 Björn "besser82" Esser 2013-09-10 04:26:57 EDT
Sorry folks.  I just made an embarassing mistake.  It's actually not a bug, but was a typo of mine.  :(

Note You need to log in before you can comment on or make changes to this bug.