Bug 1006150 - /tmp mounted at boot as tmpfs without /etc/fstab lines
/tmp mounted at boot as tmpfs without /etc/fstab lines
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 02:36 EDT by DaLiV
Modified: 2014-03-16 23:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 12:12:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DaLiV 2013-09-10 02:36:53 EDT
Description of problem:
tmpfs size is half of RAM:
- 1GB (from 2GB memory twice as recommended for FC19)
so /tmp are too small for holding:
- temporary files space required: 4-12GB
+ by Filesystem Hierarchy Standard:
/var/tmp — for files that should be preserved between reboots
/tmp — for files that should not be preserved between reboots
if application's authors had read FHS they EXPECT these directories to handle LARGE files, but in defautlt configuration by Fedora that is denied.
simple copying from big archives or from iso in mc(midnight commander) will be broken by that small amount of space tmp, desktop applications in gui also use /tmp ... and if that will be large file downloaded from internet for example in firefox - space will be not enough even to download that - will get "out of space" ...


Version-Release number of selected component (if applicable):
Linux XXX.XXX.XX 3.10.9-200.fc19.x86_64 #1 SMP Wed Aug 21 19:27:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
onboot

Actual results:
/tmp mounted as tmpfs without records in /etc/fstab 

Expected results:
/tmp mounting is controlled by /etc/fstab


Additional info:
/etc/fstab
UUID=1f1e1cd0-19e1-11e3-8ffd-0800200c9a66 /                       ext4    defaults,acl    1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults    0 0
proc                    /proc                   proc    defaults,acl    0 0
sysfs                   /sys                    sysfs   defaults,acl    0 0
LABEL=SWAP-sda2         swap                    swap    defaults,acl    0 0



# uname -a
Linux XXX.XXX.XX 3.10.9-200.fc19.x86_64 #1 SMP Wed Aug 21 19:27:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        66G   14G   50G  23% /
devtmpfs        997M     0  997M   0% /dev
tmpfs          1002M     0 1002M   0% /dev/shm
tmpfs          1002M  756K 1001M   1% /run
tmpfs          1002M     0 1002M   0% /sys/fs/cgroup
tmpfs          1002M     0 1002M   0% /tmp
# free
             total       used       free     shared    buffers     cached
Mem:       2051336     381300    1670036          0      26404     223464
-/+ buffers/cache:     131432    1919904
Swap:      1052252          0    1052252

-----
helped only manual removal of
/usr/lib/systemd/system/local-fs.target.wants/tmp.target
Comment 1 Bill Nottingham 2013-09-10 12:12:01 EDT
This is expect, per a Fedora 18 feature:
 http://fedoraproject.org/wiki/Features/tmp-on-tmpfs
Comment 2 DaLiV 2013-09-14 04:54:47 EDT
Q: Solaris uses /tmp in tmpfs for years.
A: Yes. And Linux uses it on extfs for years.
   And, BTW, Linux's faster than Solaris
   Solaris had no such a fast extfs, so it had to use tmpfs instead. :)

Q: But still solaris uses /tmp in tmpfs and has no problems
A: That's not true. Solaris users/admins actually have problems because
   of the whole swap space being exhausted by a few iso-files in /tmp.
   The matter is that /tmp is being tmpfs under Solaris for so long that
   solaris admins are used to look for free space in /tmp and fix the
   problems, that linux users never had.
   I don't want to get used to problems, do you?

Q: on SSD drives it's consume it's life
A: not all going to ssd. normal servers still use normal drives SAS SCSI ...
   housewife surelly will appreciate that ssd is configured by default... but
   it's must be selectable at install (AND UPGRADE) time for generic user as
   by default it's may be out of space on minimal system without finishing
   needed operations (by OutOfSpace condition) and so kills system ...
A+1: SSD lifetime over minimum requirements to the system ? 
   - so MUST rewrite minimal HW requirements for fedora as 16Gb of ram ... 
   - housewifes will not reads how to avoid OutOfSpace of /tmp - they simple ask to exchange OS to another ...

from: http://fedoraproject.org/wiki/Features/tmp-on-tmpfs
you also confirm that idea are quite abnormal:
+ Loss of information in /tmp when the system shuts down (for reboot or for power off) may affect people who are used to the current behavior of files persisting until they've not been touched for ten days.
+ This may also impact analysis of system crashes as /tmp will be lost on a non-clean shutdown as well as an orderly one.
+ Large files in /tmp may suddenly become more problematic. 


all comes to tmpfs (Solaris has been doing this since 1994. (Much like other Unixes, too.) Debian's next release defaults to tmpfs on /tmp, too. ArchLinux defaults to this as well. Ubuntu has plans for their 12.10 release.) - we are also under herd instinct? that why we will do things that are not right ? seems YES ... too bad if that is true ...
such critical feature (which already at begin have major inconviencies) - must be OFFERED at install and in UPGRADE times as BIG question to installer.

Note You need to log in before you can comment on or make changes to this bug.