Bug 1006189 - Grant access permission for sub packages to role 'package.admin'
Grant access permission for sub packages to role 'package.admin'
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
5.x.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: manstis
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 03:50 EDT by Toshiya Kobayashi
Modified: 2013-10-24 10:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1006188
Environment:
Last Closed: 2013-10-24 10:45:26 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshiya Kobayashi 2013-09-10 03:50:26 EDT
+++ This bug was initially created as a clone of Bug #1006188 +++

Description of problem:

With Role based user permission, 'package.admin' user can create a sub package but cannot access to the package. So 'admin' user has to grant the permission for the sub package to the 'package.admin' every time they add a sub package.

This is a feature request to grant permission for sub packages to role 'package.admin'. Because it's more natural for user's workflow.

Steps to Reproduce:
1. Enable Role based user permission
2. Create a package 'com.sample'
3. Add user 'padmin' with role 'package.admin' for 'com.sample'
4. Login as padmin
5. Create a sub package 'com.sample.subpackage'

Actual results:

padmin cannot access 'com.sample.subpackage'

Expected results:

padmin can access 'com.sample.subpackage'

Note You need to log in before you can comment on or make changes to this bug.