Bug 1006206 - CLI operation allows to add an incorrect JNDI binding which leaves the server unable to boot
CLI operation allows to add an incorrect JNDI binding which leaves the server...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Naming (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ER3
: EAP 6.2.0
Assigned To: emartins
Jan Martiska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 04:43 EDT by Jan Martiska
Modified: 2013-12-15 11:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2113 Major Resolved NamingBindingResourceDefinition attribute validation 2014-01-29 09:25:14 EST

  None (edit)
Description Jan Martiska 2013-09-10 04:43:34 EDT
In CLI, try this:
/subsystem=naming/binding=java\:jboss\/testBinding:add(binding-type=simple)

Try to restart the server, you will get:
10:34:17,537 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.server.ServerService.boot(ServerService.java:308) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:188) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[221,17]
Message: JBAS014724: Missing required attribute(s): value
	at org.jboss.as.controller.parsing.ParseUtils.missingRequired(ParseUtils.java:135) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.naming.subsystem.NamingSubsystem13Parser.parseSimpleBinding(NamingSubsystem13Parser.java:237)
	at org.jboss.as.naming.subsystem.NamingSubsystem13Parser.parseBindings(NamingSubsystem13Parser.java:193)
	at org.jboss.as.naming.subsystem.NamingSubsystem13Parser.readElement(NamingSubsystem13Parser.java:160)
	at org.jboss.as.naming.subsystem.NamingSubsystem13Parser.readElement(NamingSubsystem13Parser.java:60)
	at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:1028) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:449) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:136) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:103) [jboss-as-server-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-2.jar:1.1.0.Final-redhat-2]
	at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
	... 3 more

10:34:17,540 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.

Solution: The attribute "value" for the "add" operation should be marked as required in this case.
Comment 2 JBoss JIRA Server 2013-09-20 07:07:58 EDT
Eduardo Martins <emartins.redhat@gmail.com> made a comment on jira WFLY-2113

Commit: https://github.com/wildfly/wildfly/commit/1473445148979f083dc66d705a8d9d35f7ddd1d8
Comment 3 Jan Martiska 2013-09-27 04:33:07 EDT
Verified in 6.2.0.ER3, thanks.

Note You need to log in before you can comment on or make changes to this bug.