Bug 1006218 - Changing VM video Config - to QXL and back to cirrus - fails with errors
Changing VM video Config - to QXL and back to cirrus - fails with errors
Status: CLOSED DUPLICATE of bug 980334
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 05:09 EDT by Laura Novich
Modified: 2016-01-26 20:57 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 08:29:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laura Novich 2013-09-10 05:09:10 EDT
Description of problem:
Error changing VM configuration: XML error: ram attribute only supported for type of qxl resulted when changing the video setting for an F19 VM - when pressing apply the above error was noted.

here is the details of the error

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 2333, in _change_config_helper
    self.vm.redefine_cached()
  File "/usr/share/virt-manager/virtManager/domain.py", line 326, in redefine_cached
    self._redefine_xml(xml)
  File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 147, in _redefine_xml
    return self._redefine_helper(origxml, newxml)
  File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 137, in _redefine_helper
    self._define(newxml)
  File "/usr/share/virt-manager/virtManager/domain.py", line 775, in _define
    self.conn.define_domain(newxml)
  File "/usr/share/virt-manager/virtManager/connection.py", line 813, in define_domain
    return self.vmm.defineXML(xml)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2660, in defineXML
    if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self)
libvirtError: XML error: ram attribute only supported for type of qxl

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:(use virt manager not cmdline)
1.create a VM (I used F19)
2.change video to QXL and display to SPICE
3.start vm
4.stop VM
5.change video to cirrus


Actual results:


Expected results:


Additional info:
Comment 1 Laura Novich 2013-09-10 05:11:06 EDT
I used the following versions - 
libvirt-0.10.2-18.el6_4.9.x86_64
virt-manager-0.9.0-18.el6.x86_64
Comment 3 tingting zheng 2013-09-11 05:43:47 EDT
Would you pls refer to bug 980334 and try new version of virt-manager and python-virtinst,thanks.
Comment 4 Martin Kletzander 2013-09-12 08:29:49 EDT

*** This bug has been marked as a duplicate of bug 980334 ***

Note You need to log in before you can comment on or make changes to this bug.