Bug 1006230 - pretrans scriplet uses shell commands
pretrans scriplet uses shell commands
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sagemath (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-09-10 05:34 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: sagemath-5.9-9.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:43:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-09-10 05:34:39 EDT
Description of problem:

sage.spec has this in it's spec file:

########################################################################
%pretrans
# Temporary due to moving directory to symlink
if [ ! -L %{SAGE_ROOT}/devel -a -d %{SAGE_ROOT}/devel ]; then
    mkdir %{SAGE_SRC}
    mv %{SAGE_ROOT}/devel/* %{SAGE_SRC}
    rmdir %{SAGE_ROOT}/devel
    ln -s src %{SAGE_ROOT}/devel
fi

As per discussions here [1], and [2] I believe, it shouldn't be doing this. This causes it to fail dependency check when included in the Fedora Scientific Spin [3]:
DEBUG util.py:264:  Error creating Live CD : Dependency check failed : (('sagemath', '5.10', '2.fc20'), ('/bin/sh', ''), 0, 0, None)

[1] https://lists.fedoraproject.org/pipermail/spins/2013-September/003432.html
[2] https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#The_.25pretrans_scriptlet
[3] http://kojipkgs.fedoraproject.org//work/tasks/4116/5914116/root.log



Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.Add sagemath to a kickstart file and attempt to create a live image.
2.
3.

Actual results:

Dependency failure


Expected results:

installs correctly.

Additional info:
Comment 1 Rex Dieter 2013-09-10 07:31:55 EDT
I took care of it,

%changelog
* Tue Sep 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.10-3
- pretrans scriplet uses shell commands (#1006230)

and backported to f19/f18 branches too
Comment 2 Paulo Andrade 2013-09-10 11:31:08 EDT
(In reply to Rex Dieter from comment #1)
> I took care of it,
> 
> %changelog
> * Tue Sep 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.10-3
> - pretrans scriplet uses shell commands (#1006230)
> 
> and backported to f19/f18 branches too

Thanks!

Actually, that can be removed, as now it should be a noop.
It was added to allow clean upgrades for users that were
installing from the private repo I had at pcpa.fedorapeople.org,
as there were some directory layout changes when making sagemath
an "official" fedora package, and I am afraid having it in %pre
is unlikely to work due to the way rpm works.
Renaming symlink to/from directory is a known long standing
rpm problem.
Comment 3 Fedora Update System 2013-09-10 18:14:44 EDT
sagemath-5.10-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sagemath-5.10-3.fc20
Comment 4 Rex Dieter 2013-09-10 21:37:43 EDT
nominating freeze exception, fixes compose for Scientific spin.
Comment 5 Fedora Update System 2013-09-11 12:58:44 EDT
Package sagemath-5.10-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sagemath-5.10-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16422/sagemath-5.10-3.fc20
then log in and leave karma (feedback).
Comment 6 Kamil Páral 2013-09-12 04:55:00 EDT
Discussed at 2013-09-11 blocker review meeting [1]. Breaks compose for a non-release-blocking spin (scientific) and a tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-11/
Comment 7 Amit Saha 2013-09-12 13:15:45 EDT
I tested sagemath-5.10-3.fc20 by using it to build the Scientific spin and added my Karma accordingly.

Is there an easier way to test the fix so that I can encourage others to leave karma on it?
Comment 8 Fedora Update System 2013-09-14 21:14:57 EDT
sagemath-5.10-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sagemath-5.10-4.fc20
Comment 9 Fedora Update System 2013-09-14 21:15:52 EDT
sagemath-5.9-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sagemath-5.9-8.fc19
Comment 10 Fedora Update System 2013-09-14 21:16:55 EDT
sagemath-5.9-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sagemath-5.9-8.fc18
Comment 11 Fedora Update System 2013-09-17 13:56:16 EDT
sagemath-5.9-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sagemath-5.9-9.fc18
Comment 12 Fedora Update System 2013-09-17 13:57:42 EDT
sagemath-5.9-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sagemath-5.9-9.fc19
Comment 13 Fedora Update System 2013-09-18 22:43:05 EDT
sagemath-5.10-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-09-26 20:39:18 EDT
sagemath-5.9-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-09-26 20:41:47 EDT
sagemath-5.9-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.