Bug 1006245 - gthumb freezes when resizing images (memory leak)
gthumb freezes when resizing images (memory leak)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 05:58 EDT by Tomáš Vlček
Modified: 2013-11-10 03:08 EST (History)
1 user (show)

See Also:
Fixed In Version: gthumb-3.2.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-03 00:39:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image I wanted to resize. (2.21 MB, image/jpeg)
2013-09-10 05:58 EDT, Tomáš Vlček
no flags Details

  None (edit)
Description Tomáš Vlček 2013-09-10 05:58:50 EDT
Created attachment 795916 [details]
Image I wanted to resize.

Description of problem:
When I want resize images with gthumb, it shows a progress bar, but freezes on the first image. In System monitor I see, that it uses 1.4 GiB of memory. Hard disk works as well (probably because of swap).

I think it is a general problem, not related to my image I wanted to resize.

Version-Release number of selected component (if applicable):
gthumb-3.2.3-3.fc19 (64-bit)

How reproducible:
Try to resize image in attachment

Steps to Reproduce:
1. Open image in attachment with gthumb.
2. Click on 'Tools' button on the top.
3. Choose 'Resize images...'
4. Set: New dimensions: 800x800, Preserve original aspect ratios, Keep original format
5. Click on 'Resize' button or similar (I use Slovak interface)

Actual results:
Progress bar moves slower and slower, computer freezes, gthumb uses a lot of memory, image is not resized

Expected results:
image is resized in a few seconds

Additional info:
Comment 1 Christian Krause 2013-10-16 20:16:04 EDT
I could reproduce the problem.

Basically it is a bad UI / bad default settings. Most likely, you tried to resize to 800% in each dimension instead of 800x800 pixels. The usability of the UI is bad here: when resizing, everyone would expect the unit to be pixel, especially if the default values resemble common picture sizes.

The default unit for resizing is "percentage", but the default values are 640x480 (displayed as width 640 and heigh 640 due to preservation of the aspect ration).

So if you have a large image and scale it to 8 times in width and height, it is possible that the conversation takes a huge amount of memory.

When using more common parameters like 150%, 200% or 50% resizing works. If you want to resize to a specific size (after changing the unit to pixels), that works fine for regular sizes, too.

Please can you double-check, whether that explains your issue?


Technically, there are two issues:

- the default resize parameters should be more meaningful, e.g. 800x600 pixels or probably 50% (I'll fix this in the next update of the gthumb package in the next days)

- gthumb should handle such situations more gracefully (I'll create an upstream bug report for that)
Comment 2 Tomáš Vlček 2013-10-17 15:42:48 EDT
Yes, You are right. It does explain my issue. I used percentage instead of pixels.

I have checked it with pixels (800x600) and more common percentage (150 %) and it works for me.

Thank You very much for Your help.
Comment 3 Fedora Update System 2013-10-18 19:45:32 EDT
gthumb-3.2.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gthumb-3.2.4-1.fc20
Comment 4 Fedora Update System 2013-10-18 19:47:23 EDT
gthumb-3.2.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gthumb-3.2.4-1.fc19
Comment 5 Fedora Update System 2013-10-19 05:12:50 EDT
Package gthumb-3.2.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gthumb-3.2.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19478/gthumb-3.2.4-1.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-11-03 00:39:11 EDT
gthumb-3.2.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-11-10 03:08:53 EST
gthumb-3.2.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.