Bug 1006285 - Remove testscope for jbpm-designer-client
Remove testscope for jbpm-designer-client
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ---
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 07:42 EDT by Ryan Zhang
Modified: 2013-10-30 02:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 02:10:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kverlaen: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2013-09-10 07:42:10 EDT
Description of problem:
The jbpm-designer-client is defined as test scope in jbpm-designer/jbpm-designer-backend/pom.xml(See below). Might I suggest that we remove the test scope?
In product build, we will remove the test scope, but jbpm-designer-client shouldn't be removed in this case. 

So I am asking if we could remove the "test" scope for jbpm-designer/jbpm-designer-backend/pom.xml.
    <dependency>
      <groupId>org.jbpm</groupId>
      <artifactId>jbpm-designer-client</artifactId>
      <scope>test</scope>
    </dependency>


Version-Release number of selected component (if applicable):


How reproducible:
jbpm-designer CR2

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Kris Verlaenen 2013-09-24 19:56:59 EDT
Unclear why this would be necessary, we added test scope on purpose (and it seems to work for community build), unclear why it would need to be removed?
Comment 3 Ryan Zhang 2013-09-30 03:28:46 EDT
After discussed with Tiho, I think the concern for using "test" scope is to exclude them in war.

I think "provided" is the preferable "<scope>" for dependencies in this case  rather than "test" if you don't want to include it in war. 

The reason I am asking to remove it is that:
We need to remove "test scope" depenencies in product build since it cause much more extra efforts to build them , importing them etc.
But in this case, we hit error after remove a jbpm-designer artifact.
Comment 6 Kris Verlaenen 2013-09-30 10:20:24 EDT
Ryan, I guess it makes sense to exclude artefacts that are only used in test-scope if you're not interested in those.  But I don't think that you should exclude an artefact from the entire build when it's used as a test scope in one component (as it might just as well be used in compile-scope in another).  I guess you should only exclude an artefact if it's only used in test-scope in all components, right?
Comment 7 Prakash Aradhya 2013-10-17 13:52:01 EDT
Why is this dev - ?  
Looks like the work is still pending on Ryan..

Note You need to log in before you can comment on or make changes to this bug.