Bug 1006290 - Cannot change OS type of existing template
Cannot change OS type of existing template
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Martin Betak
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 07:51 EDT by Jiri Belka
Modified: 2013-10-02 11:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 11:03:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19130 None None None Never

  None (edit)
Description Jiri Belka 2013-09-10 07:51:56 EDT
Description of problem:

Cannot change OS type of existing template.

popup:
======

Error while executing action:

fffff:

    Failed updating the properties of the VM template.

engine.log:
===========

2013-09-10 13:49:19,435 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp-/127.0.0.1:8702-4) The message key UpdateVmTemplate is missing from bundles/ExecutionMessages
2013-09-10 13:49:19,535 WARN  [org.ovirt.engine.core.bll.UpdateVmTemplateCommand] (ajp-/127.0.0.1:8702-4) CanDoAction of action UpdateVmTemplate failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__VM_TEMPLATE,VMT_CANNOT_UPDATE_ILLEGAL_FIELD

Version-Release number of selected component (if applicable):
is13

How reproducible:
100%

Steps to Reproduce:
1. try to change os type of an existing template
2.
3.

Actual results:
not possible

Expected results:
why not?

Additional info:
Comment 1 Einav Cohen 2013-09-11 15:36:20 EDT
there is a chance that you cannot change the OSType of a Template by design. 
if so - field in the GUI should be disabled. 
otherwise - CanDoAction should be fixed.
Comment 2 Michal Skrivanek 2013-10-02 09:37:57 EDT
martin, pls check it's not because of timezone...:)
Comment 3 Martin Betak 2013-10-02 10:23:27 EDT
This has been already fixed u/s some time ago (viz tracker).
And no, it wasn't caused by timezone ;-)

Note You need to log in before you can comment on or make changes to this bug.