Bug 1006305 - Data migration to PostgreSQL fails for very large lobs
Data migration to PostgreSQL fails for very large lobs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Martin Minar
:
Depends On:
Blocks: sat560-upgrades
  Show dependency treegraph
 
Reported: 2013-09-10 08:13 EDT by Milan Zazrivec
Modified: 2016-07-03 20:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-utils-2.0.2-10 rhn-upgrade-5.6.0.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:26:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2013-09-10 08:13:16 EDT
Description of problem:
Data migration from an older Oracle schema to Satellite 5.6 @ PostgreSQL
will fail for large LOBs (currently larger than 10M).

Version-Release number of selected component (if applicable):
rhn-upgrade-5.6.0.31-1

How reproducible:
Always

Steps to Reproduce:
1. Satellite 5.5 or older with a registered client
2. Have the client remotely run a script which will create >= 10MB output
3. Migrate to Satellite 5.6 @ PostgreSQL

Actual results:
spacewalk-dump-schema fails with the following error:

DBD::Oracle::st fetchrow_arrayref failed: ERROR fetching field 3 of 8. LOB
value truncated from 14465734 to 10000000. DBI attribute LongReadLen too small
and/or LongTruncOk not set [for Statement "select * from
rhnserveractionscriptresult"] at ./spacewalk-dump-schema line 437.

Expected results:
Schema migration succeeds.

Additional info:
N/A
Comment 1 Milan Zazrivec 2013-09-10 08:21:35 EDT
spacewalk.git master: 8e8cc44ec35bbc839c110b1ad9d80366bf75933f
Comment 4 Clifford Perry 2013-10-01 15:26:08 EDT
Satellite 5.6 has been released. This bug tracked under Upgrades. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1393.html

Note You need to log in before you can comment on or make changes to this bug.