Bug 1006307 - Openstack Installer: packstack fails in Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 1:
Openstack Installer: packstack fails in Execution of '/usr/bin/keystone --end...
Status: CLOSED DUPLICATE of bug 1006278
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 08:15 EDT by Omri Hochman
Modified: 2013-09-10 08:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 08:33:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2013-09-10 08:15:52 EDT
Openstack Installer: packstack fails in Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 1:

Environment :
--------------
rpm -qa | grep packstack
openstack-packstack-2013.2.1-0.7.dev752.el6.noarch

steps:
-------
1) sudo yum install -y http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm
2) register to proper channels  
3) yum-config-manager --enable epel-testing
4)sudo yum install -y openstack-packstack
5)sudo yum install python-netaddr -y (workaround for netaddr issue)
6)packstack --allinone --os-neutron-install=n --debug

7)Apply workaround for: ERROR : 'CONFIG_NOVA_NETWORK_VLAN_START'
https://review.openstack.org/#/c/45826/1/packstack/plugins/nova_300.py

8)run again: packstack --allinone --os-neutron-install=n --debug


Results : 
---------
Adding Nova Scheduler manifest entries...              [ DONE ]
Adding Nova VNC Proxy manifest entries...              [ DONE ]
Adding Nova Common manifest entries...                 [ DONE ]
Adding Nova Network manifest entries...                [ DONE ]
Adding OpenStack Client manifest entries...            [ DONE ]
Adding Horizon manifest entries...                     [ DONE ]
Adding Swift Keystone manifest entries...              [ DONE ]
Adding Swift builder manifest entries...               [ DONE ]
Adding Swift proxy manifest entries...                 [ DONE ]
Adding Swift storage manifest entries...               [ DONE ]
Adding Swift common manifest entries...                [ DONE ]
Adding Ceilometer manifest entries...                  [ DONE ]
Adding Ceilometer Keystone manifest entries...         [ DONE ]
Preparing servers...                                   [ DONE ]
Adding Nagios server manifest entries...               [ DONE ]
Adding Nagios host manifest entries...                 [ DONE ]
Adding post install manifest entries...                [ DONE ]
Installing Dependencies...                             [ DONE ]
Copying Puppet modules and manifests...                [ DONE ]
Applying Puppet manifests...
Applying 10.35.160.13_prescript.pp
10.35.160.13_prescript.pp :                 [ DONE ]                 
Applying 10.35.160.13_mysql.pp
Applying 10.35.160.13_qpid.pp
10.35.160.13_mysql.pp :                         [ DONE ]         
10.35.160.13_qpid.pp :                           [ DONE ]        
Applying 10.35.160.13_keystone.pp
Applying 10.35.160.13_glance.pp
Applying 10.35.160.13_cinder.pp
                                                                                            [ ERROR ]

ERROR : Error during puppet run : err: /Stage[main]/Keystone::Roles::Admin/Keystone_role[admin]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 1: <attribute 'message' of 'exceptions.BaseException' objects> (HTTP Unable to establish connection to http://127.0.0.1:35357/v2.0/OS-KSADM/roles)
Please check log file /var/tmp/packstack/20130910-145634-pKe1X5/openstack-setup.log for more information



openstack-setup.log
---------------------
ESC[0;36mDebug: Using settings: adding file resource 'rrddir': 'File[/var/lib/puppet/rrd]{:loglevel=>:debug, :links=>:follow, :group=>"puppet", :ensure=>:directory, :backup=>false, :owner=>"
puppet", :mode=>"750", :path=>"/var/lib/puppet/rrd"}'ESC[0m
ESC[0;36mDebug: /File[/var/lib/puppet/rrd]/seluser: Found seluser default 'system_u' for /var/lib/puppet/rrdESC[0m
ESC[0;36mDebug: /File[/var/lib/puppet/rrd]/selrole: Found selrole default 'object_r' for /var/lib/puppet/rrdESC[0m
ESC[0;36mDebug: /File[/var/lib/puppet/rrd]/seltype: Found seltype default 'puppet_var_lib_t' for /var/lib/puppet/rrdESC[0m
ESC[0;36mDebug: /File[/var/lib/puppet/rrd]/selrange: Found selrange default 's0' for /var/lib/puppet/rrdESC[0m
ESC[0;36mDebug: Finishing transaction 70179785807300ESC[0m
ESC[0;36mDebug: Received report to process from rose12.qa.lab.tlv.redhat.comESC[0m
ESC[0;36mDebug: Processing report from rose12.qa.lab.tlv.redhat.com with processor Puppet::Reports::StoreESC[0m

2013-09-10 14:02:59::DEBUG::sequences::48::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 46, in run
    self.function(config)
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 181, in applyPuppetManifest
    waitforpuppet(currently_running)
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 168, in waitforpuppet
    validate_puppet_logfile(log)
  File "/usr/lib/python2.6/site-packages/packstack/modules/ospluginutils.py", line 145, in validate_puppet_logfile
    raise PackStackError(message)
PackStackError: Error during puppet run : Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:
35357/v2.0/ role-list' returned 1: <attribute 'message' of 'exceptions.BaseException' objects> (HTTP Unable to establish connection to http://127.0.0.1:35357/v2.0/OS-KSADM/roles)

2013-09-10 14:02:59::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 894, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 667, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 697, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:3
5357/v2.0/ role-list' returned 1: <attribute 'message' of 'exceptions.BaseException' objects> (HTTP Unable to establish connection to http://127.0.0.1:35357/v2.0/OS-KSADM/roles)

2013-09-10 14:02:59::INFO::run_setup::598::root:: Removing /var/tmp/packstack/353d59072baf43c8ac68682aa6902888 on 10.35.99.11 (if it is a remote host)
2013-09-10 14:02:59::DEBUG::shell::61::root:: # ============ ssh : '10.35.99.11' ==========
Comment 1 Omri Hochman 2013-09-10 08:20:17 EDT
It seems that after this failure the keystone service is down: 

/etc/init.d/openstack-keystone status
keystone dead but pid file exists


* I've tried to start the keystone service , drop the openstack and re-install using packstack but the problem still occurred.
Comment 2 Omri Hochman 2013-09-10 08:33:54 EDT

*** This bug has been marked as a duplicate of bug 1006278 ***

Note You need to log in before you can comment on or make changes to this bug.