Bug 1006340 - [Admin Portal] OS type is wrong when importing VM with RHEV origin from an export domain
[Admin Portal] OS type is wrong when importing VM with RHEV origin from an ex...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity high
: ---
: 3.3.0
Assigned To: Roy Golan
Ilanit Stein
virt
: Regression
Depends On:
Blocks: 3.3snap1
  Show dependency treegraph
 
Reported: 2013-09-10 09:08 EDT by Jiri Belka
Modified: 2014-01-21 17:34 EST (History)
12 users (show)

See Also:
Fixed In Version: is20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log, vdsm.log, c8dc7c6a-f410-4d56-9e31-802d67907155.ovf (242.70 KB, application/x-tar)
2013-09-10 09:08 EDT, Jiri Belka
no flags Details
Import Virtual Machine dialog (100.87 KB, image/png)
2013-09-10 09:09 EDT, Jiri Belka
no flags Details
VM OVF files from 3.2 & 3.3, engine.log (3.3), vdsm.log (3.2) (530.79 KB, application/x-gzip)
2013-10-29 11:37 EDT, Pavel Novotny
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19774 None None None Never
oVirt gerrit 19794 None None None Never
oVirt gerrit 20271 None None None Never

  None (edit)
Description Jiri Belka 2013-09-10 09:08:15 EDT
Created attachment 795998 [details]
engine.log, vdsm.log, c8dc7c6a-f410-4d56-9e31-802d67907155.ovf

Description of problem:
OS type is wrong when importing VM with RHEV origin (I had such VMs from 3.2 setup) from an export domain, I did import Windows 2008 32bit and it is shown as 'Other OS'.

Version-Release number of selected component (if applicable):
is13

How reproducible:
100%

Steps to Reproduce:
1. export a VM
2. import the VM and check its OS type
3.

Actual results:
not same

Expected results:
should be kept

Additional info:
if exported VM has ovirt origin, it looks OK
Comment 1 Jiri Belka 2013-09-10 09:09:08 EDT
Created attachment 795999 [details]
Import Virtual Machine dialog
Comment 2 Michal Skrivanek 2013-10-01 04:43:36 EDT
roy, can you please take a look. Probably related to osinfo changes...
Comment 6 Pavel Novotny 2013-10-29 11:33:05 EDT
FailedQA in rhevm-3.3.0-0.28.beta1.el6ev.noarch (is20).

OS type of VMs exported in RHEVM 3.2 and imported in 3.3 is still reset to 'Other OS'. 

Verification steps:
1. In RHEVM 3.2 (rhevm-3.2.4-0.44.el6ev.noarch - sf21), create a VM with OS type `Windows 7 X64`.
2. Export the VM
3. Import the VM in RHEVM 3.3 and check the OS type - it's `Other OS`.

In the VM's OVF file the OS type is set to `Windows7x64` (see attached `rhevm32_vm-w7x64.ovf`).
It looks like problem only with handling the older 3.2 OVF format. With export & import of VM in 3.3, the OS type stays the same.
Comment 7 Pavel Novotny 2013-10-29 11:37:12 EDT
Created attachment 817122 [details]
VM OVF files from 3.2 & 3.3, engine.log (3.3), vdsm.log (3.2)

engine.log:
2013-Oct-29, 13:08 - import of VM exported in RHEVM 3.2
2013-Oct-29, 13:36 - import of VM exported in the same RHEVM 3.3
Comment 8 Shai Revivo 2013-11-03 04:09:26 EST
in build 21
Comment 9 Ilanit Stein 2013-11-05 07:44:00 EST
Verified on is21.

Followed comment #6 instuctions, only with 'Windows XP'.
Os type remained the same in the imported VM, 'Windows XP', and not 'Other OS'.
Comment 10 Ilanit Stein 2013-11-05 08:22:38 EST
Also checked .ovf files:

In export domain - 
<Info>Guest Operating System</Info>
<Description>WindowsXP</Description>

In master domain (to which vm was imported) -
<Info>Guest Operating System</Info>
<Description>windows_xp</Description>
Comment 11 Itamar Heim 2014-01-21 17:31:46 EST
Closing - RHEV 3.3 Released
Comment 12 Itamar Heim 2014-01-21 17:31:47 EST
Closing - RHEV 3.3 Released
Comment 13 Itamar Heim 2014-01-21 17:34:23 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.