Bug 1006342 - Remove runtime dependency on python-pbr
Remove runtime dependency on python-pbr
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: RC
: Havana
Assigned To: Alan Pevec
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 09:11 EDT by Xavier Queralt
Modified: 2016-04-26 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-18 15:46:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Queralt 2013-09-10 09:11:06 EDT
Description of problem:

neutron package still needs python-pbr on runtime but it is not in the package dependencies.

This dependency was removed in all the other openstack packages. See the patch for nova: http://pkgs.fedoraproject.org/cgit/openstack-nova.git/tree/0002-remove-runtime-dep-on-python-pbr.patch

Version-Release number of selected component (if applicable):

2013.2-0.7.b3.fc20

How reproducible:

always

Steps to Reproduce:
1. Install with packstack: packstack --allinone
2. At some point it will fail with the error below while configuring neutron
3.

Actual results:

http://fpaste.org/38345/13788183/

Expected results:


Additional info:

The package in the el6-havana repository will work because it depends on python-pbr but it could be removed too.
Comment 1 Nikola Dipanov 2013-09-10 11:10:18 EDT
It seems that this bug can be worked around by manually installing python-pbr on the affected fedora system, and then running packstack.
Comment 2 Terry Wilson 2013-09-10 13:51:30 EDT
openstack-neutron-2013.2-0.8.b3.fc20 just includes the Requires: python-pbr to work around the issue (the el6 builds have done this for a long time now). I'll leave this open to remind me to look into removing the runtime dependency, but to be honest distro-specific patches for something like this kind of irritate me since python-pbr actually is packaged. Yeah, you can reduce it to a BuildRequires, but if it is a bad idea to use something for getting the version info at runtime, then that should really just be fixed upstream IMHO.
Comment 3 Alan Pevec 2013-11-14 16:02:47 EST
>  should really just be fixed upstream

Fix is coming, I hope for Icehouse: https://github.com/openstack/oslo.version
So PBR as runtime dep will be just a historical anecdote.
Comment 5 Lars Kellogg-Stedman 2015-03-18 15:46:50 EDT
Neutron no longer requires python-pbr at runtime.

Note You need to log in before you can comment on or make changes to this bug.