This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1006360 - Broken redirection when deleting last entry of DNS resource record
Broken redirection when deleting last entry of DNS resource record
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 09:52 EDT by Dmitri Pal
Modified: 2014-06-17 20:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-3.3.1-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2013-09-10 09:52:13 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/3907

Reproduction:
1. add new dns record
2. open details page of the record
3. delete the entry (there should be only one in the record)
4. redirection dialog with text "DNS record was deleted because it contained no data. You will be redirected to DNS Zone." should appear
5. confirm the dialog
6. User is not redirected

Expected:
6. User should be redirected resource records page of parent zone

Cause:
* Invalid call - `navigation.show_entity_page`. Should be `navigation.show_entity`.
Comment 3 Varun Mylaraiah 2014-02-03 05:23:40 EST
Verified in ipa-server-3.3.3-15.el7.x86_64

Step
1. add new dns record
2. open details page of the record
3. delete the entry (there should be only one in the record)
4. redirection dialog with text "DNS record was deleted because it contained no data. You will be redirected to DNS Zone."
5. confirm the dialog
6. User is redirected to resource records page of parent zone.
Comment 4 Ludek Smid 2014-06-13 07:48:27 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.