Bug 1006366 - dnf makecache runs on LiveCD
dnf makecache runs on LiveCD
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 09:59 EDT by Kamil Páral
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnf-0.4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 03:13:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-09-10 09:59:30 EDT
Description of problem:
With F20 Alpha TC5 Live, anaconda pulls in dnf into the compose. After being inside the LiveCD for a moment, I noticed dnf taking considerable cpu time (it was a slow machine and it was quite visible). It seems that the makecache timer is running on LiveCD as well. That downloads repo metadata and performs some operations on them, probably. That a) slows down operation/installation b) uses more RAM (because the root disk is memory-mapped).

We should stop caching repo metadata on livecd, it's really not necessary. It can be achieved for example by using this systemd condition:
> ConditionKernelCommandLine=!rd.live.image

That should disable the service/timer on LiveCD.

Version-Release number of selected component (if applicable):
F20 Alpha TC5 Live
dnf-0.4.0-1.gitbfccb5c.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. boot F20 Alpha TC5 Live
2. wait 10 or more minutes, see top
3. check /var/cache/dnf
Comment 1 Ales Kozumplik 2013-09-10 10:12:07 EDT
Hi Kamil, thanks for catching and reporting this. I've pushed a fix:

https://github.com/akozumpl/dnf/commit/598daf3aa8183c50533a29982e0454fcf165e280

Will be included with dnf-0.4.1.
Comment 2 Fedora Update System 2013-09-16 09:40:59 EDT
dnf-0.4.1-1.git55e6369.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.1-1.git55e6369.fc20
Comment 3 Fedora Update System 2013-09-16 12:15:01 EDT
Package dnf-0.4.1-1.git55e6369.fc20, librepo-1.1.0-1.fc20, hawkey-0.4.1-1.git6f35513.fc20, libcomps-0.1.3-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.1-1.git55e6369.fc20 librepo-1.1.0-1.fc20 hawkey-0.4.1-1.git6f35513.fc20 libcomps-0.1.3-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16868/librepo-1.1.0-1.fc20,hawkey-0.4.1-1.git6f35513.fc20,libcomps-0.1.3-5.fc20,dnf-0.4.1-1.git55e6369.fc20
then log in and leave karma (feedback).
Comment 4 Ales Kozumplik 2013-10-25 03:13:53 EDT
dnf-0.4.1 has been pushed and superseded. Closing this.

Note You need to log in before you can comment on or make changes to this bug.