Bug 1006396 - Business-central does not scale
Business-central does not scale
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity high
: ER5
: 6.0.0
Assigned To: Jan
Zuzana Krejčová
:
Depends On: 1007720 998940
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-10 10:36 EDT by Zuzana Krejčová
Modified: 2014-08-06 16:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (425.00 KB, application/zip)
2013-09-10 10:36 EDT, Zuzana Krejčová
no flags Details
Data modeler low res (93.51 KB, image/png)
2013-10-01 04:11 EDT, Pedro Zapata
no flags Details
screenshots with ER4 and 1280x800 (203.00 KB, application/zip)
2013-10-15 09:48 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-10 10:36:36 EDT
Created attachment 796033 [details]
screenshots

Description of problem:
The GUI does not scale well. If you use a smaller screen, it is a right mess. The whole app is affected, though problems I've recently run into are with these components especially:
- Home page
- Data Modeler
- Designer - simulation results
- Project Explorer drop downs
- Project editor
- Process & Task Dashboards
Comment 1 Pedro Zapata 2013-09-12 04:27:48 EDT
What's the minimum resoulution is expected to support? It's not realistic to assume it can scale down to any resolution, given there's a lot of information at once, but we should set a minimal resolution where it should look acceptable (let's say 1280x768 or something similar).
Comment 2 Lukáš Petrovický 2013-09-12 04:32:19 EDT
Good point. Prakash, can you please provide the minimal resolution that the apps should work with?
Comment 3 Prakash Aradhya 2013-09-16 22:14:16 EDT
The reality is we have a UI workbench that is too busy with too many gadgets.  Well it is what we have is what we have.  When we were doing the assessment last week we all felt the heat of how little view we have on Linux boxes.  
On top of that when you do screen sharing through Elluminate or Webex, eventhough you are using a higher resolution, we are constrained by those sharing softwares.

We may not attain the best solution by setting the resolution guidelines.
In a larger scale we should we think about enabling options for users to expand individual tool areas to maximize the landscape on their desktops.

In general 1280x768 is a reasonable minimum we should target.


Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 4 Pedro Zapata 2013-10-01 04:11:40 EDT
Created attachment 805756 [details]
Data modeler low res
Comment 5 Pedro Zapata 2013-10-01 04:27:59 EDT
After a review with 1280x700, the following areas need to be improved.

- Project screen > Dependencies
- Project Explorer drop downs
- Process dashboards (charts width can be made 100px smaller each)

Other screens were already fixed

- Data modeler (was fixed and now behaves correctly in low resolution)
- Home page. Looks fine at this resolution.
- Process modeler. Simulation area is too big, but the only solution would be make the chart smaller.

Of course, the work area is very minimal, and that can only be fixed with a different layout and application style. 

Font sizes are big (=bootstrap styling), but since they scale well the user can easily reduce the size by using his browser settings (usually CTRL+mouse wheel down) to reach the desired font sizes.
Comment 6 JBoss Product and Program Management 2013-10-06 21:43:31 EDT
This bug report previously had all acks and release flag approved.
However since at least one of its acks has been changed, the
release flag has been reset to ? by the bugbot (pm-jboss). The
ack needs to become approved before the release flag can become
approved again.
Comment 7 JBoss Product and Program Management 2013-10-07 13:22:32 EDT
This bug report previously had all acks and release flag approved.
However since at least one of its acks has been changed, the
release flag has been reset to ? by the bugbot (pm-jboss). The
ack needs to become approved before the release flag can become
approved again.
Comment 8 JBoss Product and Program Management 2013-10-08 04:54:22 EDT
This bug report previously had all acks and release flag approved.
However since at least one of its acks has been changed, the
release flag has been reset to ? by the bugbot (pm-jboss). The
ack needs to become approved before the release flag can become
approved again.
Comment 9 Jan 2013-10-09 05:06:02 EDT
Some changes have been applied to the project editor screen (dependencies), as per Comment 5.
With respect to the Process dashboard charts, their actual size is a trade-off between visibility and resolution. If we scale them down, by reducing their size, when rendered on a screen with higher resolution, they will NOT scale back up, i.e. they will keep the preset size. This will definitely not be beneficial when the charts are visualizing lots of data (e.g. lots of pieces in a pie chart). We have therefore opted not to change the size of the out-of-the-box charts. If necessary, in specific cases the user can always downsize them by accessing the chart properties.
Comment 10 Zuzana Krejčová 2013-10-15 09:47:20 EDT
Using 1280x800 resolution, I have noted that:

- login screen is too big - there is more of the background picture down below the username and password fields (same for 1280x720),

(- Home page is still slightly longer as well, but nothing too bad, everything is visible,)

- the right part of the 'Data modeler' does not have enough space - the middle part could scale down a bit more, I think, there's still a bit extra space there and it would help,

- below the used area of the 'Data modeler', there is further blank space that just makes the page unnecessarily longer,

- the 'Data modeler' has scrollbars for each of its components it seems. This means that the right part, when it has too little space, has it's own scrollbar. This scrollbar is at the bottom and is hidden if you have Problems tab open as well. It might be better to use just the one scrollbar for the whole width of the 'Data modeler',

- Project Editor is still too big. GAV section has a lot of empty space that makes it too big to fit well. The same goes for dependencies - Group ID isn't completely readable. Metadata and Imports sections are similar to GAV. Kbases and ksessions section is also too big,

- Process & Task Dashboards - if the page is wider than your screen, you are out of luck, no scrollbar is available to get to the right side. Zooming out helps with this. Unfortunately, it doesn't help with unreadable parts of the graphs.

For these reasons I have to put it back on assigned. There is still work to be done on this, even though it does look and work better.
Comment 11 Zuzana Krejčová 2013-10-15 09:48:21 EDT
Created attachment 812540 [details]
screenshots with ER4 and 1280x800
Comment 12 Edson Tirelli 2013-10-16 09:41:13 EDT
This was fixed after CR4, based on the date of the fix.
Comment 13 Zuzana Krejčová 2013-12-11 09:22:30 EST
The worst is fixed. Some details remain, but that can be covered by separate BZs if necessary (Designer already has it's own set of BZs).

Note You need to log in before you can comment on or make changes to this bug.