Bug 1006397 - Candlepin Pool locking code does not work with MySQL
Candlepin Pool locking code does not work with MySQL
Status: CLOSED DUPLICATE of bug 1006010
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: candlepin-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 10:37 EDT by Andrew Edwards
Modified: 2016-04-18 02:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 09:20:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hibernate exception while trying to create multiple entitlements from 1 pool. Candlepin 0.8.15.2 with mysql (16.06 KB, text/plain)
2013-09-10 10:39 EDT, Andrew Edwards
no flags Details

  None (edit)
Description Andrew Edwards 2013-09-10 10:37:26 EDT
Description of problem:
Hibernate exceptions raised when binding to a pool multiple times in parallel.

Version-Release number of selected component (if applicable):
Candlepin 0.8.15.2

How reproducible:


Steps to Reproduce:
1. Create an owner with 1 entitlement
2. Create multiple consumers
3. Attempt to bind all the consumers to the same entitlement simultaneously

Actual results:
Hibernate exceptions raised. 
Sep 09 03:22:09 [http-8080-6] ERROR org.candlepin.exceptions.mappers.CandlepinExceptionMapper - Runtime Error Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [org.candlepin.model.Pool#8a85f9823e3d5e43013e3e0af77e0f36] at org.hibernate.persister.entity.AbstractEntityPersister.check:1,782

Expected results:
All attempts to bind to the pool are completed successfully up to the quantity of the pool

Additional info:
example script
for i in $(seq 1 16); do ( ssh <host.ip.address$i> "/usr/sbin/subscription-manager attach --pool=<pool_id>"&  ); done;
Comment 1 Andrew Edwards 2013-09-10 10:39:30 EDT
Created attachment 796037 [details]
hibernate exception while trying to create multiple entitlements from 1 pool. Candlepin 0.8.15.2 with mysql
Comment 2 Andrew Cathrow 2013-09-23 08:12:31 EDT
This is causing issues with RHEL-OSP customers.
Please can we prioritize this.
Comment 3 Devan Goodwin 2013-09-23 09:20:13 EDT
Closing as duplicate, other bug has more info and aligned to correct component/team.

*** This bug has been marked as a duplicate of bug 1006010 ***

Note You need to log in before you can comment on or make changes to this bug.