Bug 1006411 - Hardcoded references to "localhost:8080"
Hardcoded references to "localhost:8080"
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
All All
high Severity high
: ER6
: 6.0.0
Assigned To: Kris Verlaenen
Marek Baluch
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-10 11:00 EDT by Josh West
Modified: 2014-08-06 16:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh West 2013-09-10 11:00:49 EDT
Description of problem:

There are few resources in BPMS that hard code localhost:8080. When using a port offset this breaks the designer and has some other unknown affects.  

The current workaround to fix the JBPM designer is to set the 'designer.url' property to the appropriate port when using a port offset.  The expectation would be detect the main web port instead of having to control it through a property. 

There is a KIE widget that hardcodes localhost:8080 while trying to load a couple javascript and a css file. This should use a relative path instead of hardcoding the full server url. I don't know what functionality this breaks (potentially prevents the ability to save data model).

# is backbone used, and will this load?
./standalone/deployments/business-central.war/org.kie.workbench.KIEWebapp/defaults/formwidgets/backboneformsinclude.fw:<script src="http://localhost:8080/designer/lib/backbone-forms-min.js" charset="utf-8"></script>     
./standalone/deployments/business-central.war/org.kie.workbench.KIEWebapp/defaults/formwidgets/backboneformsinclude.fw:<script src="http://localhost:8080/designer/lib/backbone-forms-list-min.js" charset="utf-8"></script>
./standalone/deployments/business-central.war/org.kie.workbench.KIEWebapp/defaults/formwidgets/backboneformsinclude.fw:<link href="http://localhost:8080/designer/lib/backbone-forms-default.css" rel="stylesheet" />

# Property must be overridden when using a port offset - can this be detected automatically instead?
###    group.addConfigItem( configurationFactory.newConfigItem( "designer.url", "http://localhost:8080" ) );
Binary file ./standalone/deployments/business-central.war/WEB-INF/classes/org/kie/workbench/backend/AppSetup.class matches
./standalone/deployments/business-central.war/WEB-INF/classes/org/kie/workbench/backend/AppSetup.java:  "http://localhost:8080" ) );  


Version-Release number of selected component (if applicable):

BPMSv6 ER2

How reproducible:

100% of the time for designer issue
Unknown affects for the 

Steps to Reproduce:
1. Install BPMS on EAP 6. 
2. Start the server with a port offset (ex: bin/standalone.sh -Djboss.socket.binding.port-offset=1)
3a. Check that you can edit a JBPM process
3b. Try to create a data model and save it
Comment 1 Josh West 2013-09-10 11:03:05 EDT
There likely more reference to localhost:8080 in the html, javascript, and css files.
Comment 3 Prakash Aradhya 2013-09-16 21:41:42 EDT
We absolutely need to fix this for GA.  But it is OK if it is not tackled for Beta.

Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 4 Tihomir Surdilovic 2013-09-17 19:05:15 EDT
Removed all references to localhost from the form widgets. Tested designer with -Djboss.socket.binding.port-offset=1 and things seem fine. If there are issues with data modeler please assign to appropriate devels for that. Fix for designer in its master and 6.0.x branches.
Comment 8 Marek Baluch 2013-10-23 05:40:24 EDT
File AppSetup.class still hardcodes http://localhost:8080. If this is intended and does not represent a problem then please explain why. Thanks.
Comment 9 Tihomir Surdilovic 2013-10-23 06:46:48 EDT
You mean https://github.com/droolsjbpm/jbpm-designer/blob/master/jbpm-designer-standalone/src/main/java/org/jbpm/designer/uberfire/backend/server/impl/AppSetup.java - there are no references to localhost. Maybe tho it comes from somewhere else so will take a look.
Comment 11 Kris Verlaenen 2013-10-31 12:58:08 EDT
Marek, we believe this is no longer used, verifying.
Comment 13 Marek Baluch 2013-10-31 13:08:02 EDT
If you can confirm that it's not used anywhere then please move the state back to ON_QA and I will close it. Thanks a lot guys!
Comment 14 Kris Verlaenen 2013-11-28 17:36:49 EST
Removed property:
http://github.com/droolsjbpm/kie-wb-distributions/commit/1ad2245f7
Comment 15 Marek Baluch 2013-12-20 14:55:23 EST
Verified on ER6.

Note You need to log in before you can comment on or make changes to this bug.