Bug 1006423 - system-switch-displaymanager does not support sddm
system-switch-displaymanager does not support sddm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-switch-displaymanager (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 11:20 EDT by Andre Robatino
Modified: 2015-04-07 05:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-26 16:18:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-09-10 11:20:51 EDT
Description of problem:
[root@localhost ~]# system-switch-displaymanager sddm
The graphical display manager sddm is not supported yet.

I can switch to sddm manually using systemctl commands. Since sddm is now the default DM for KDE, this really should work.

Version-Release number of selected component (if applicable):
system-switch-displaymanager-1.3-3.fc20.noarch
Comment 1 Bas Mevissen 2015-02-25 11:16:20 EST
SDDM support is now added to system-switch-displaymanager-1.4-1. Unfortunately, with (at least) sddm-0.10.0-3.fc21 on a Fedora 21 x86_64 system it gives the following error:

ERROR: SDDM is not installed on your machine! to install SDDM, please type yum install sddm

The reason for this error is that system-switch-displaymanager looks for the sddm binary in /usr/sbin instead of /usr/bin.

Fix is:

--- /usr/share/system-switch-displaymanager/system-switch-displaymanager-helper.orig	2015-02-10 15:46:52.000000000 +0100
+++ /usr/share/system-switch-displaymanager/system-switch-displaymanager-helper	2015-02-25 17:11:42.094453180 +0100
@@ -59,7 +59,7 @@
     ;;
   SDDM)
     DISPLAYMANAGER=SDDM
-    [ ! -x /usr/sbin/sddm ] && error SDDM sddm
+    [ ! -x /usr/bin/sddm ] && error SDDM sddm
     DM=sddm
     ;;

With this change, SDDM is supported properly on Fedora 21.
Comment 2 Ngo Than 2015-02-26 16:18:11 EST
it's fixed, i will build it into rawhide today. thanks for your report.
Comment 3 Jean-Paul Lambrechts 2015-04-05 01:21:58 EDT
Current available version of system-switch-displaymanager in Fedora 21 is 1.4.1 and it appears to still have this bug. There is a simple workaround: 
in /usr/share/system-switch-displaymanager/system-switch-displaymanager-helper,
line 64, in the test for sddm availability, replace /usr/sbin/sddm with /usr/bin/sddm. It does the same thing as the patch from Bas Mevissen.
The switch to sddm works after this change (tested with the gui).
Comment 4 Bas Mevissen 2015-04-07 05:12:22 EDT
There is a newer version (1.5-1) in Koji that seems to have the issue fixed. See http://koji.fedoraproject.org/koji/buildinfo?buildID=615547

This package is fine too on fc21 (tested it myself). It just needs to tagged as fc21 update. Ngo, can you please do that anytime soon?

Note You need to log in before you can comment on or make changes to this bug.