Bug 1006452 - packstack [havana]: fail to install AIO with Error during puppet run
packstack [havana]: fail to install AIO with Error during puppet run
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 12:03 EDT by Dafna Ron
Modified: 2014-01-15 07:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 07:29:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (1.21 KB, application/x-xz)
2013-09-10 12:03 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-09-10 12:03:03 EDT
Created attachment 796067 [details]
log

Description of problem:

trying to install AIO I get this error: 

ERROR : Error during puppet run : err: /Stage[main]//Exec[ntpdate]/returns: change from notrun to 0 failed: /usr/sbin/ntpdate y returned 1 instead of one of [0] at /var/tmp/packstack/5595556ab3344777b1abc230746c12c8/manifests/10.35.64.69_ntpd.pp:85

Version-Release number of selected component (if applicable):

openstack-packstack-2013.2.1-0.7.dev752.el6.noarch

How reproducible:


Steps to Reproduce:
1. install AIO 
2.
3.

Actual results:

we fail install with: 
ERROR : Error during puppet run : err: /Stage[main]//Exec[ntpdate]/returns: change from notrun to 0 failed: /usr/sbin/ntpdate y returned 1 instead of one of [0] at /var/tmp/packstack/5595556ab3344777b1abc230746c12c8/manifests/10.35.64.69_ntpd.pp:85



Expected results:

installation should succeed


Additional info: ful log 

2013-09-10 18:47:16::ERROR::ospluginutils::144::root:: ^[[0;36mnotice: /File[ntp_config]/content: content changed '{md5}32a4dd13b44b8c5ec7ca69872ac7f796' to '{md5}fcbfe294c9c05c0ef5939af11fd0f071'^[[0m
^[[0;36mnotice: /Stage[main]//Exec[stop-ntpd]/returns: executed successfully^[[0m
^[[1;35merr: /Stage[main]//Exec[ntpdate]/returns: change from notrun to 0 failed: /usr/sbin/ntpdate y returned 1 instead of one of [0] at /var/tmp/packstack/5595556ab3344777b1abc230746c12c8/manifests/10.35.64.69_ntpd.pp:85^[[0m
^[[0;36mnotice: /Stage[main]//Service[ntpd]: Dependency Exec[ntpdate] has failures: true^[[0m
^[[0;33mwarning: /Stage[main]//Service[ntpd]: Skipping because of failed dependencies^[[0m
^[[0;36mnotice: Finished catalog run in 0.72 seconds^[[0m

2013-09-10 18:47:16::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : err: /Stage[main]//Exec[ntpdate]/returns: change from notrun to 0 failed: /usr/sbin/ntpdate y returned 1 instead of one of [0] at /var/tmp/packstack/5595556ab3344777b1abc230746c12c8/manifests/10.35.64.69_ntpd.pp:85^[[0m
Comment 1 Mike Tomczyk 2013-10-30 15:27:51 EDT
I am seeing the same error message when I try to install on a VMware Guest 

2013-10-30 10:47:59::ERROR::run_setup::910::root:: Traceback (most recent call l                                              ast):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line                                               891, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line                                               663, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line                                               693, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line                                               573, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line                                               552, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py                                              ", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py",                                               line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py",                                               line 52, in run
    raise SequenceError(str(ex))
SequenceError: Failed to run remote script: no package provides puppet
Loaded plugins: product-id, security, subscription-manager
Comment 2 Alvaro Lopez Ortega 2014-01-15 07:29:38 EST
ntp is run three times in recent versions. This issue should be fixed already.

Note You need to log in before you can comment on or make changes to this bug.