Bug 1006459 - yum installation of openstack-dasboard fails due to packages conflicts
yum installation of openstack-dasboard fails due to packages conflicts
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python-django-horizon (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 12:14 EDT by Jakub Libosvar
Modified: 2013-09-10 13:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 12:58:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Libosvar 2013-09-10 12:14:17 EDT
Description of problem:
openstack-dashboard requires python-django-appconf which requires Django (version doesn't matter).
openstack-dashboard also requires python-django-horizon which has restriction dependency: python-django < 1.5
due to this restriction python-django14 is supposed to be installed, but also python-django. Those two packages conflict.

Version-Release number of selected component (if applicable):
openstack-dashboard 2013.1.3-2.fc19


How reproducible:
Always

Steps to Reproduce:
1. Have not installed python-django
2. yum install openstack-dashboard
3.

Actual results:
---> Package python-django.noarch 0:1.5.2-1.fc19 will be installed
---> Package python-django14.noarch 0:1.4.6-1.fc19 will be installed
--> Processing Conflict: python-django14-1.4.6-1.fc19.noarch conflicts python-django >= 1.5


Expected results:
only one version of django is installed

Additional info:
package: openstack-dashboard.noarch 2013.1.3-2.fc19
  dependency: python-django-appconf
   provider: python-django-appconf.noarch 0.6-1.fc19
    package: python-django-appconf.noarch 0.6-1.fc19
     dependency: Django
      provider: python-django14.noarch 1.4.6-1.fc19
      provider: python-django.noarch 1.5.2-1.fc19
  dependency: python-django-horizon >= 2013.1.3
   provider: python-django-horizon.noarch 2013.1.3-2.fc19
    package: python-django-horizon.noarch 2013.1.3-2.fc19
     dependency: python-django < 1.5
      provider: python-django14.noarch 1.4.6-1.fc19
Comment 1 Matthias Runge 2013-09-10 12:58:01 EDT
I think it's a yum bug.

It seems to work, eg. when doing
yum install python-django-horizon openstack-dashboard

see

http://openstack.redhat.com/forum/discussion/500/rdo-install-issues-on-f19-eth1-django14#Item_8

I agree, this is not ideal, but fixed on f20, or when using the rdo version from
http://openstack.redhat.com
Comment 2 Matthias Runge 2013-09-10 13:00:15 EDT
Uhm, sorry, I don't want to be rude.

The dashboard on f19 does not work wih django 1.5, python-django-appconf and also the compressor work on both versions, so it would be plainly wrong to restrict them just to django 1.4

Note You need to log in before you can comment on or make changes to this bug.