Bug 1006491 - google-guice should install no_aop JAR in addition to the main JAR
google-guice should install no_aop JAR in addition to the main JAR
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: google-guice (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 1006461
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 13:30 EDT by Mikolaj Izdebski
Modified: 2013-10-10 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.1.3-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 10:52:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-09-10 13:30:09 EDT
Description of problem:
google-guice should install no_aop JAR in addition to the main JAR.
Currently Maven uses Guice JAR without classifier no_aop, which causes some problems with aopalliance and cglib.

Version-Release number of selected component (if applicable):
3.1.3-5
Comment 1 Mikolaj Izdebski 2013-09-10 13:31:44 EDT
Fixed in google-guice-3.1.3-6
Comment 2 Mikolaj Izdebski 2013-09-10 13:32:17 EDT
The fix is commited, but package is not built yet because of missing dependency on munge-maven-plugin.
Comment 3 Mikolaj Izdebski 2013-10-10 10:52:11 EDT
I believe that this bug is fixed in google-guice-3.1.3-8,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=467216

Note You need to log in before you can comment on or make changes to this bug.