This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1006539 - SIGSEGV - ~NonSharedCharacterBreakIterator () from /lib/libQtWebKit.so.4
SIGSEGV - ~NonSharedCharacterBreakIterator () from /lib/libQtWebKit.so.4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qtwebkit (Show other bugs)
20
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
Depends On:
Blocks: ARMTracker F20AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-09-10 15:12 EDT by Paul Whalen
Modified: 2013-09-17 22:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: qtwebkit-2.3.2-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 22:20:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace (16.42 KB, text/plain)
2013-09-12 09:50 EDT, Paul Whalen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
WebKit Project 101337 None None None Never

  None (edit)
Description Paul Whalen 2013-09-10 15:12:33 EDT
Description of problem:
When attempting to enter form data in konqueror on ARM the browser will crash. 

Version-Release number of selected component (if applicable):
kde-baseapps-4.11.0-1.fc20.armv7hl
qtwebkit-2.3.2-2.fc20.armv7hl

How reproducible:
everytime

Steps to Reproduce:
1. Boot F20 Alpha-TC5 KDE.
2. Launch Konqueror and browse to google. Try to enter form data.

Actual results:
Browser will close with Segmentation fault.


Expected results:
Successful query. 

Additional info:
With gdb:
Program received signal SIGSEGV, Segmentation fault.
0xaed4c984 in WebCore::NonSharedCharacterBreakIterator::~NonSharedCharacterBreakIterator () from /lib/libQtWebKit.so.4
Comment 1 Tim Flink 2013-09-11 11:08:48 EDT
I attempted to reproduce using the f20 alpha tc5 x64 kde live image. I was able to log in to the fedora wiki and search with google without konqueror crashing
Comment 2 Rex Dieter 2013-09-11 11:10:07 EDT
Any chance of a backtrace or abrt report?
Comment 3 Tim Flink 2013-09-12 04:20:29 EDT
Discussed during the 2013-09-11 Fedora 20 alpha blocker bug review meeting [1].

While not a great situation to be in, this is only affecting ARM and could be fixed with an update post-release as it doesn't affect lives. Rejected as a blocker for F20 alpha but a tested fix would be considered past freeze - accepted as a freeze exception.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-11/
Comment 4 Paul Whalen 2013-09-12 09:50:15 EDT
Created attachment 796870 [details]
backtrace

Backtrace attached
Comment 5 Rex Dieter 2013-09-12 09:54:06 EDT
Thread 1 (Thread 0xb423b000 (LWP 891)):
[KCrash Handler]
#6  0xaed5b984 in WebCore::NonSharedCharacterBreakIterator::~NonSharedCharacterBreakIterator () from /lib/libQtWebKit.so.4
#7  0xaeb2af78 in WebCore::numCharactersInGraphemeClusters () from /lib/libQtWebKit.so.4
#8  0xae86ad64 in limitLength () from /lib/libQtWebKit.so.4
#9  0xae86bffc in WebCore::TextFieldInputType::handleBeforeTextInsertedEvent () from /lib/libQtWebKit.so.4
#10 0xae825560 in WebCore::HTMLInputElement::defaultEventHandler () from /lib/libQtWebKit.so.4
...

I don't see any line numbers listed, incomplete -debuginfo ?
Comment 6 Rex Dieter 2013-09-12 09:55:02 EDT
come to think of it, it may be because we limit debuginfo in qtwebkit packaging, else it is ginormous... :(
Comment 7 Paul Whalen 2013-09-12 11:57:45 EDT
Rex, I installed all -debuginfo packages available. Any recommendations?
Comment 8 Rex Dieter 2013-09-12 12:03:44 EDT
Nothing yet, we'll make-do the best we can with the information available.
Comment 9 Rex Dieter 2013-09-12 12:06:00 EDT
May be relevant,
https://bugs.webkit.org/show_bug.cgi?id=101337
Comment 10 Rex Dieter 2013-09-12 13:10:52 EDT
%changelog
* Thu Sep 12 2013 Rex Dieter <rdieter@fedoraproject.org> 2.3.2-3
- SIGSEGV - ~NonSharedCharacterBreakIterator (#1006539, webkit#101337)
Comment 11 Rex Dieter 2013-09-12 13:11:29 EDT
Mind trying this out?  (when it finishes building of course):

https://koji.fedoraproject.org/koji/buildinfo?buildID=464112
Comment 12 Paul Whalen 2013-09-12 17:25:33 EDT
Excellent, working on Trimslice and Wandboard with that build.
Comment 13 Fedora Update System 2013-09-12 22:18:47 EDT
qtwebkit-2.3.2-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qtwebkit-2.3.2-3.fc20
Comment 14 Fedora Update System 2013-09-17 22:20:31 EDT
qtwebkit-2.3.2-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.