Bug 1006623 - Cross-context forward/include call from another web app breaks HttpRequestContext cleanup
Cross-context forward/include call from another web app breaks HttpRequestCon...
Status: CLOSED DUPLICATE of bug 956631
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stuart Douglas
Marek Schmidt
Russell Dickenson
:
Depends On: 1003581
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 19:55 EDT by Lyle Wang
Modified: 2013-09-19 03:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: WeldListener would clean up the bound context request when servlet processed finished, even if it was being sent to another servlet Consequence: A NullPointerException would result when the subsequent servlet tried to access the context Fix: Do not clean up the bound context if the servlet is being redirected. Result: No exception occurs when getRequestDispatcher().include() is used to forward requests between servlets.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 20:14:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker Weld-1415 Major Resolved Cross-context include call from another web app breaks HttpRequestContext cleanup 2014-07-15 07:37:32 EDT

  None (edit)
Description Lyle Wang 2013-09-10 19:55:07 EDT
Description of problem:

Reference JIRA https://issues.jboss.org/browse/Weld-1415

Version-Release number of selected component (if applicable):

weld-core-1.1.13.Final-redhat-1
Comment 1 James Livingston 2013-09-10 20:14:10 EDT

*** This bug has been marked as a duplicate of bug 956631 ***
Comment 2 JBoss JIRA Server 2013-09-18 12:49:10 EDT
Ron Šmeral <rsmeral@redhat.com> updated the status of jira WELD-1415 to Reopened
Comment 3 JBoss JIRA Server 2013-09-18 12:49:10 EDT
Ron Šmeral <rsmeral@redhat.com> made a comment on jira WELD-1415

Only the inclusion is resolved. The cross-context forwarding still does not work. See the updated test: https://github.com/weld/core/pull/372
Comment 4 JBoss JIRA Server 2013-09-19 03:12:45 EDT
Jozef Hartinger <jharting@redhat.com> updated the status of jira WELD-1415 to Resolved
Comment 5 JBoss JIRA Server 2013-09-19 03:12:45 EDT
Jozef Hartinger <jharting@redhat.com> made a comment on jira WELD-1415

Closing not to break release notes. I am going to create another issue for forwards.

Note You need to log in before you can comment on or make changes to this bug.