Bug 1006649 - Component Service metrics missing from DMR integration
Component Service metrics missing from DMR integration
Status: CLOSED WORKSFORME
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: tcunning
Jiri Pechanec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 23:04 EDT by Keith Babo
Modified: 2016-01-27 11:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The "show-metrics" operation allows the caller to retrieve the metrics for promoted services and references but does not allow one to retrieve the metrics for the component services or component references. This is because it does not collecting metrics for component services that are not promoted and, additionally, if a component service is promoted more than once, the metrics may not be accurate for the composite services promoting it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-14 09:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTESB-3621 Major Closed Component Service metrics missing from DMR integration 2016-01-27 11:10 EST
JBoss Issue Tracker SWITCHYARD-1694 Major Pull Request Sent Component Service metrics missing from DMR integration 2015-07-24 15:03:41 EDT

  None (edit)
Description Keith Babo 2013-09-10 23:04:47 EDT
The show-metrics operation allows the caller to retrieve the metrics for the promoted services and references but does not allow the retrieval of the metrics for the component services nor component references.
Comment 1 JBoss JIRA Server 2013-09-10 23:14:12 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1694 to Resolved
Comment 2 JBoss JIRA Server 2013-09-10 23:14:12 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1694

pushed
Comment 6 Jiri Pechanec 2013-10-22 07:08:56 EDT
ER6 - the metrics are zero

Try bpm-service QS and call from CLI

[standalone@localhost:9999 subsystem=switchyard] :show-metrics(service-name="{urn:switchyard-quickstart:bpm-service:1.0}Shipping", type="*")
{
    "outcome" => "success",
    "result" => [{
        "name" => "{urn:switchyard-quickstart:bpm-service:1.0}Shipping",
        "application" => "{urn:switchyard-quickstart:bpm-service:1.0}osdemo",
        "successCount" => 0,
        "faultCount" => 0,
        "totalCount" => 0,
        "averageTime" => big decimal 0.0,
        "minTime" => 0,
        "maxTime" => 0,
        "totalTime" => 0L,
        "operations" => [{
            "name" => "ship",
            "successCount" => 0,
            "faultCount" => 0,
            "totalCount" => 0,
            "averageTime" => big decimal 0.0,
            "minTime" => 0,
            "maxTime" => 0,
            "totalTime" => 0L
        }],
        "references" => undefined
    }]
}
Comment 7 Keith Babo 2013-11-07 08:35:58 EST
Rob - can you have a look at this?
Comment 8 Rob Cernich 2013-11-07 11:39:04 EST
It appears the metrics do not appear when using the wildcard, but you can get them by setting type="componentService"
Comment 9 Rob Cernich 2013-11-07 11:41:19 EST
Sorry, my previous comment is invalid.  The behavior is the same whether using * or componentService.  The data returned is invalid.
Comment 10 Rob Cernich 2013-11-07 11:48:38 EST
Metrics are only gathered for composite services, not for component services.

Metrics for composite services are aggregated on the component service, which they promote.  This means that if a component service is promoted twice, and a single message is sent through each composite service, the metrics for each composite service will show two messages being processed (because they metrics are tracked on the component service).

Metrics are gathered for component references, but these do not filter down to the actual component service/composite reference being invoked (well, maybe in the case of a composite reference).

To summarize, the issue is that we are not collecting metrics for component services that are not promoted.  And, if a component service is promoted more than once, the metrics may not be accurate for the composite services promoting it.
Comment 11 JBoss JIRA Server 2013-11-07 12:40:27 EST
Rob Cernich <rcernich@redhat.com> updated the status of jira SWITCHYARD-1694 to Reopened
Comment 12 JBoss JIRA Server 2013-11-07 12:40:27 EST
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1694

Need to rework how metrics are aggregated/calculated.
Comment 13 kconner 2015-01-27 13:05:47 EST
There is an existing PR for this, it should be updated and tested.

Should also consider updating the JON plugin to retrieve this information.
Comment 14 tcunning 2015-07-14 09:46:19 EDT
For Fuse 6.2.1, we are moving to tracking all issues in JIRA.    Logged https://issues.jboss.org/browse/ENTESB-3621 to track this issue.
Comment 15 tcunning 2015-07-14 09:46:52 EDT
Closing - updates should go in the ENTESB JIRA logged.
Comment 16 JBoss JIRA Server 2015-07-24 15:19:03 EDT
Tom Cunningham <tcunning@redhat.com> updated the status of jira ENTESB-3621 to Resolved
Comment 17 JBoss JIRA Server 2016-01-27 11:10:36 EST
Stefan Veres <sveres@redhat.com> updated the status of jira ENTESB-3621 to Closed

Note You need to log in before you can comment on or make changes to this bug.