Bug 1006650 - qemu should give a more friendly prompt when didn't specify read-only for VHDX format disk
qemu should give a more friendly prompt when didn't specify read-only for VHD...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
: TestOnly
Depends On:
Blocks: 1006651
  Show dependency treegraph
 
Reported: 2013-09-10 23:15 EDT by Sibiao Luo
Modified: 2014-10-14 02:51 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1006651 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-09-10 23:15:02 EDT
Description of problem:
boot guest with a VHDX format disk which did not specify read-only, qemu will quit with a "'vhdx' invalid format" prompt, I suggest that QEMU should give a more friendly prompt for users, like: VHDX should use a read-only drive.

Version-Release number of selected component (if applicable):
host info:
2.6.32-414.el6.x86_64
qemu-kvm-0.12.1.2-2.400.el6.x86_64
guet info:
2.6.32-414.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a VHDX image via hyper-V.
2.copy the vhdx image into localhost and boot guest with this VHDX image as a data disk which did not specify read-only for it.
e.g:...-drive file=/home/sluo-win2012-64bit.vhdx,if=none,format=vhdx,id=drive-data-disk,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,bus=pci.0,addr=0x7,drive=drive-data-disk,id=data-disk
qemu-kvm: -drive file=/home/sluo-win2012-64bit.vhdx,if=none,format=vhdx,id=drive-data-disk,cache=none,werror=stop,rerror=stop: 'vhdx' invalid format
/etc/qemu-ifdown: could not launch network script

Actual results:
after step 2, qemu will quit with a "'vhdx' invalid format" prompt.

Expected results:
I suggest that QEMU should give a more friendly prompt for users, like: VHDX should use a read-only drive(just like bug 999788).

Additional info:
Comment 5 Sibiao Luo 2014-07-28 05:19:14 EDT
Verify this issue on qemu-kvm-rhev-0.12.1.2-2.431.el6.x86_64.

host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-493.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.431.el6.x86_64

e.g.:...-drive file=/home/my-data-disk.vhdx,if=none,format=vhdx,id=drive-data-disk,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,bus=pci.0,addr=0x7,drive=drive-data-disk,id=data-disk
qemu-kvm: -drive file=/home/my-data-disk.vhdx,if=none,format=vhdx,id=drive-data-disk,cache=none,werror=stop,rerror=stop: 'vhdx' can be only used as read-only device.

Best Regards,
sluo
Comment 6 errata-xmlrpc 2014-10-14 02:51:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.