Bug 1006699 - need add "interface" to virt-xml-validate manual page
need add "interface" to virt-xml-validate manual page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: Upstream
Depends On:
Blocks: 1006700
  Show dependency treegraph
 
Reported: 2013-09-11 03:00 EDT by EricLee
Modified: 2014-10-14 00:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-32.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1006700 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:17:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description EricLee 2013-09-11 03:00:27 EDT
Description of problem:
need add "interface" to virt-xml-validate manual page

Version-Release number of selected component (if applicable):
# rpm -qa libvirt qemu-kvm ; uname -r
qemu-kvm-rhev-0.12.1.2-2.400.el6.x86_64
libvirt-0.10.2-24.el6.x86_64
2.6.32-396.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
# man virt-xml-validate
....
       Valid schema names currently include

       "domain"
           The schema for the XML format used by guest domains configuration

       "network"
           The schema for the XML format used by virtual network configuration

       "storagepool"
           The schema for the XML format used by storage pool configuration

       "storagevol"
           The schema for the XML format used by storage volume descriptions

       "nodedev"
           The schema for the XML format used by node device descriptions

       "capability"
           The schema for the XML format used to declare driver capabilities
....

there is no "interface" in it, however we can use like this:
# cat eth1.xml
<interface type='ethernet' name='eth1'>
  <start mode='onboot'/>
  <mac address='00:15:17:62:ae:e8'/>
</interface>

# virt-xml-validate eth1.xml interface
eth1.xml validates

Actual results:
see description

Expected results:
should include interface

Additional info:
it is also reproduced both in rhel7 and upstream.
Comment 2 Alex Jia 2013-09-11 05:18:04 EDT
Patch on upstream:
http://www.redhat.com/archives/libvir-list/2013-September/msg00546.html
Comment 3 Jiri Denemark 2013-09-13 09:14:19 EDT
"interface" is not the only schema missing. Fixed upstream by the following commits (in v1.1.2-120-g4583ccb):

commit ab4304b7e0b90a18c5ec528028d0f1a6d1317c8c
Author: Eric Blake <eblake@redhat.com>
Date:   Mon Aug 19 16:32:31 2013 -0600

    virt-xml-validate: add missing schemas
    
    We were failing to autoprobe which schema to use for several
    top-level XML elements.
    
    * tools/virt-xml-validate.in (TYPE): Recognize <domainsnapshot>,
    <filter>, and <secret>.
    
    Signed-off-by: Eric Blake <eblake@redhat.com>

commit 4583ccbcf72d5cfb3f078d208c3efbf9aab0d799
Author: Alex Jia <ajia@redhat.com>
Date:   Wed Sep 11 11:47:14 2013 +0800

    tools: add missing 'interface' type and update man page
    
    Signed-off-by: Alex Jia <ajia@redhat.com>
Comment 8 EricLee 2014-04-14 05:39:40 EDT
Verified pass in libvirt-0.10.2-32.el6:

# man virt-xml-validate
.....

       "domainsnapshot"
           The schema for the XML format used by domain snapshot
           configuration
.....

       "nwfilter"
           The schema for the XML format used by network traffic filters

       "secret"
           The schema for the XML format used by secrets descriptions

       "interface"
           The schema for the XML format used by physical host interfaces

Have added above four schemas.
Comment 11 errata-xmlrpc 2014-10-14 00:17:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.