Bug 1006721 - xmvn 1.0.0 includes sources jar in the binary packages.
xmvn 1.0.0 includes sources jar in the binary packages.
Status: CLOSED DUPLICATE of bug 1006512
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 03:44 EDT by Mattias Ellert
Modified: 2013-09-11 07:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 06:43:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2013-09-11 03:44:34 EDT
Description of problem:

The new xmvn version includes sources jars in the rpm packages it creates

Version-Release number of selected component (if applicable):

xmvn-1.0.0-2.fc21

How reproducible:

Always

Steps to Reproduce:
1. Build a java package using xmvn

Actual results:

See e.g. https://koji.fedoraproject.org/koji/rpminfo?rpmID=4399385

The list of files in the RPM is:

/usr/share/java/jglobus/jsse-sources.jar
/usr/share/java/jglobus/jsse.jar
/usr/share/maven-effective-poms/JPP.jglobus-jsse.pom
/usr/share/maven-fragments/jglobus-jsse.xml
/usr/share/maven-poms/JPP.jglobus-jsse.pom

Expected results:

The same SRPM built on Fedora 20 (using xmvn 0.5.1-4.fc20):

https://koji.fedoraproject.org/koji/rpminfo?rpmID=4399401

/usr/share/java/jglobus/jsse.jar
/usr/share/maven-effective-poms/JPP.jglobus-jsse.pom
/usr/share/maven-fragments/jglobus-jsse.xml
/usr/share/maven-poms/JPP.jglobus-jsse.pom

Additional info:

Sources should not be in a runtime package. For C and C++ packages sources are installed as part of the debuginfo package. If you want the sources jars in the distribution for some reason I think they should be in a something like a debuginfo package. But maybe the inclusion of the sources jars was just a mistake.
Comment 1 Stanislav Ochotnicky 2013-09-11 06:43:18 EDT

*** This bug has been marked as a duplicate of bug 1006512 ***

Note You need to log in before you can comment on or make changes to this bug.