Bug 1006742 - Poor performance using kvm with fully virtualized network (e1000).
Poor performance using kvm with fully virtualized network (e1000).
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 04:39 EDT by Jan ONDREJ
Modified: 2013-09-19 01:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 01:50:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2013-09-11 04:39:58 EDT
Description of problem:
Network speed on fully virtualized network card (for example e1000) is very slow in KVM guests. Same problems on multiple dell servers. The use bnx2 network card driver. Switching to virtio in guest will fix this problem.

Version-Release number of selected component (if applicable):
All 3.10.* kernels:
kernel-3.10.9-100.fc18.x86_64
kernel-3.10.10-200.fc19.x86_64

NOT affected:
kernel-3.9.5-301.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot Fedora KVM host with 3.10.* kernel (or maybe higher)
2. install KVM guest with netcard <model type='e1000'/>
3. run in guest: wget -O /dev/null ftp://host/large_file

Actual results:
not more than 10MB/s transfer with kernels 3.10.*
Average speed should be in kB/s.

Expected results:
Transfer at least at 30MB/s.

Additional info:
Changing guest netcard to virtio fixes my problems, so this looks to be not an host physical network card problem.
Also rebooting host to 3.9 kernel fixes this problem, so it's not a network problem.

I have same problem with 2 different DELL machines, which use bnx2 network card. Unable to reproduce with my noname workstation with Fedora and kernel3.10.

Tested also fully virtualized disk, where speeds are slower (virtio 150MB/s, IDE 110MB/s) but not so much. I think it's expected, that virtio should be faster.

Does not matter, which guest OS is installed, same problem with Fedora and Windows.
Comment 1 Michele Baldessari 2013-09-11 15:33:23 EDT
Hi Jan,

so just in order to get a very clear picture:
A) Host kernel with kernel-3.9.5-301.fc19.x86_64 and guest with fully
emulated e1000 network card gives you a ~30MB/s

B) Exact same host but with kernel-3.10.x and with the exact same guest with
e1000 network card gives you ~10MB/s

Is my understanding correct? So no other changes on the host except the kernel and the guest is always the same, right?

What kernel/fedora version does the guest use?

Thanks,
Michele
Comment 2 Jan ONDREJ 2013-09-12 05:04:11 EDT
Here are some tests. There is host kernel version and still same guest network configuration:

host 3.9.5-301.fc19.x86_64, guest: <model type='e1000'/> 
100%[======================>] 4,519,362,560 58.8M/s   in 74s
2013-09-12 07:51:16 (58.2 MB/s) - `/dev/null' saved [4519362560]

host 3.9.5-301.fc19.x86_64, guest: <model type='virtio'/>
100%[======================>] 4,519,362,560 59.6M/s   in 72s    
2013-09-12 07:54:12 (60.1 MB/s) - `/dev/null' saved [4519362560]

----
host 3.10.9-100.fc18.x86_64, guest: <model type='virtio'/> 
100%[======================>] 4,519,362,560 60.5M/s   in 71s
2013-09-12 09:48:07 (60.6 MB/s) - `/dev/null' saved [4519362560]

host 3.10.9-100.fc18.x86_64, guest: <model type='e1000'/>
 0% [                       ] 1,664,856  139K/s  eta 21h 43m

----
host 3.10.10-200.fc19.x86_64, guest: <model type='virtio'/>
100%[======================>] 4,519,362,560 60.2M/s   in 73s     
2013-09-12 10:59:20 (58.8 MB/s) - `/dev/null' saved [4519362560]

host 3.10.10-200.fc19.x86_64, guest: <model type='e1000'/>
 0% [                       ] 674,424  64.6K/s  eta 23h 17m

----
host 3.10.10-200.fc19.x86_64, host speed for comparison
100%[======================>] 4,519,362,560 61.1MB/s   in 70s
2013-09-12 08:24:39 (61.2 MB/s) - '/dev/null' saved [4519362560]



Guest version:
Linux vpn-server 3.6.11-4.fc16.x86_64 #1 SMP Tue Jan 8 20:57:42 UTC 2013
x86_64 x86_64 x86_64 GNU/Linux

This is one of my old testing guests, but same problem with newer guests too.
And also same problem for windows guests.

Testing command:
wget -O /dev/null \
ftp://158.197.16.70/pub/fedora/linux/releases/19/Fedora/i386/iso/Fedora-19-i386
Comment 3 Josh Boyer 2013-09-18 16:55:33 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 4 Jan ONDREJ 2013-09-19 01:50:59 EDT
Unable to reproduce with kernel 3.11.1-200.fc19.x86_64. Looks like it's fixed. Closing bug. Reopen if you consider to fix this for Fedora 18. I can't test on Fedora 18. Thank you for fix.

Note You need to log in before you can comment on or make changes to this bug.