Bug 10068 - Default operator group is 0 (root)
Summary: Default operator group is 0 (root)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: amanda (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-08 16:46 UTC by Stelian Pop
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 14:08:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stelian Pop 2000-03-08 16:46:52 UTC
[operator@predator /root]$ grep operator /etc/passwd
operator:*:11:0:operator:/root:

             ^^^

[operator@predator /root]$ grep disk /etc/group
disk::6:root

     ^^^

I thought that amanda uses operator.disk permissions...

Stelian.

Comment 1 Marc MERLIN 2000-03-08 19:09:59 UTC
The binaries that need disk GID are SGID disk

It'd be better to use a backup UID and GID, but I didn't want to change the
package too much compared to the prior version, or do patching of /etc/passwd

Comment 2 Tim Powers 2000-03-20 14:08:59 UTC
Will fix in next release. There will be an errata update for amanda, but this
won't be in it until the next release. I don't want to change amanda too much
for the 6.x releases. FYI- an errata will be out for amanda since it was
erroniously buklt without dump.

Tim


Note You need to log in before you can comment on or make changes to this bug.