Bug 1006802 - Several problems related to branding change in EAP 6.2.0
Several problems related to branding change in EAP 6.2.0
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Server (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER4
: EAP 6.2.0
Assigned To: Vladimir Dosoudil
:
Depends On:
Blocks: eap62-beta-blockers
  Show dependency treegraph
 
Reported: 2013-09-11 06:09 EDT by Nikoleta Ziakova
Modified: 2013-12-15 11:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:21:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP 6.1 welcome page logo (7.35 KB, image/png)
2013-09-29 18:38 EDT, Paul Gier
no flags Details
RHJBoss EAP logo with transparent background (4.01 KB, image/png)
2013-09-30 09:15 EDT, Catherine Robson
no flags Details
RHJBoss EAP logo with gray gradient background (4.74 KB, image/png)
2013-09-30 09:16 EDT, Catherine Robson
no flags Details
Image showing all changes to reflect branding name change (47.48 KB, image/png)
2013-09-30 09:17 EDT, Catherine Robson
no flags Details
Image showing all changes to reflect branding name change (46.80 KB, image/png)
2013-09-30 10:07 EDT, Catherine Robson
no flags Details

  None (edit)
Description Nikoleta Ziakova 2013-09-11 06:09:43 EDT
Description of problem:
EAP 6.2.0 ER1 welcome page does not reflect branding change - renaming product from JBoss Enterprise Application Platform to Red Hat JBoss Enterprise Application Platform.

Steps to Reproduce:
1. start EAP
2. go to localhost:8080

Actual results:
1. http://localhost:8080/images/prod_name.png contains old logo
2. incorrect product name in: Your JBoss Enterprise Application Platform is running.
3. Documentation URL points to incorrect documentation: https://access.redhat.com/site/documentation/JBoss_Enterprise_Application_Platform/

Expected results:
1. prod_name.png should contain new product logo
2. new product name should be used - Red Hat JBoss Enterprise Application Platform
3. correct URL is https://access.redhat.com/site/documentation/Red_Hat_JBoss_Enterprise_Application_Platform/
Comment 1 Nikoleta Ziakova 2013-09-25 02:47:39 EDT
Another problem on the welcome page:

Actual results:
4. Incorrect abbreviated product name in: Welcome to EAP 6

Expected results:
4. Welcome to JBoss EAP 6
Comment 2 Paul Gier 2013-09-27 16:27:38 EDT
This PR includes the text updates:
https://github.com/jbossas/jboss-eap/pull/484

I'm still following up on who can make the necessary change to the logo.
Comment 4 Paul Gier 2013-09-29 18:38:06 EDT
Created attachment 804817 [details]
EAP 6.1 welcome page logo

Attaching the current logo for comparison
Comment 5 Catherine Robson 2013-09-30 09:15:20 EDT
Created attachment 805196 [details]
RHJBoss EAP logo with transparent background

I'm adding two variations of the logo - one with a transparent background and one with the gray gradient.

I am also including a screenshot of how I expect the welcome page to look.  As mentioned, the terminology on the page needs to change as well.  It should say "Red Hat JBoss EAP 6" not just "JBoss EAP 6".  I have removed the branding from the second line so that we can keep that sentence briefer.
Comment 6 Catherine Robson 2013-09-30 09:16:05 EDT
Created attachment 805201 [details]
RHJBoss EAP logo with gray gradient background
Comment 7 Catherine Robson 2013-09-30 09:17:37 EDT
Created attachment 805207 [details]
Image showing all changes to reflect branding name change
Comment 8 Nikoleta Ziakova 2013-09-30 10:01:36 EDT
(In reply to Catherine Robson from comment #5)
> should say "Red Hat JBoss EAP 6" not just "JBoss EAP 6".

Is this correct? I thought the full product name is "Red Hat JBoss Enterprise Application Platform" and the abbreviation is "JBoss EAP", see Description in BZ 971187. 

Should "Red Hat JBoss EAP" be used instead of "JBoss EAP" or is it only because there is the version "6" used? Could you please provide more information about what forms of product name are correct?
Comment 9 Catherine Robson 2013-09-30 10:03:53 EDT
@Nikoleta,

My apologies - you are correct that JBoss EAP is the correct shortened version. Sorry about that, I got mixed up!
Comment 10 Catherine Robson 2013-09-30 10:07:57 EDT
Created attachment 805224 [details]
Image showing all changes to reflect branding name change

Updating example screen to reflect using "JBoss EAP"
Comment 11 Vladimir Dosoudil 2013-09-30 13:22:24 EDT
The PR includes updated logo:
https://github.com/jbossas/jboss-eap/pull/495
Comment 12 Nikoleta Ziakova 2013-10-04 04:35:02 EDT
Verified for EAP 6.2.0 ER4

Note You need to log in before you can comment on or make changes to this bug.