Bug 1006839 - Tech_Preview_Bug: Information is wrong in "Connection Pooling with JDBC cache store" row in the Table 1.1. JBoss Data Grid Features.
Tech_Preview_Bug: Information is wrong in "Connection Pooling with JDBC cache...
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
unspecified
All All
unspecified Severity low
: ---
: 6.2.0
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 07:15 EDT by Kenjiro Nakayama
Modified: 2013-11-07 18:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 01:01:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2013-09-11 07:15:11 EDT
Document URL: 
Technical Preview Feature Information for Red Hat JBoss Data Grid 6.0.1: 
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6/html-single/Technical_Preview/index.html

Section Number and Name: 
1.3. JBoss Data Grid Features and Usage Modes 
Table 1.1. JBoss Data Grid Features

Describe the issue: 
Information is wrong in "Connection Pooling with JDBC cache store" row in the Table 1.1. JBoss Data Grid Features.

Suggestions for improvement: 
* Check Client-Server Mode
  reason: Connection pool is provided as JDG feature.

* Uncheck Library Mode
  reason: Connection pool is used in EAP's
Comment 1 Kenjiro Nakayama 2013-09-11 07:16:56 EDT
NOTE: I point to "Connection Pooling with JDBC cache store" row.

* Check Client-Server Mode
  reason: Connection pool is provided as JDG feature.

* Uncheck Library Mode
  reason: Connection pool is used in EAP's
Comment 4 Misha H. Ali 2013-09-11 09:39:41 EDT
I'm fairly sure this is a JDG feature, and not EAP. Copying tristan and martin in case one of them can help clarify this issue. While this is a problem reported on older versions of docs, this should be fixed in the 6.2 release if, in fact, connection pooling is an EAP feature and not a JDG feature as indicated.
Comment 5 Martin Gencur 2013-09-27 02:38:42 EDT
Let me clarify this...
Now I'm referring to section "3.6.2. Connection management (pooling)" of Infinispan user guide - http://infinispan.org/docs/6.0.x/user_guide/user_guide.html

In client-server mode, the connection pooling is provided through a DataSource that is available as one of JDG server's subsystems.

In library mode, we can either run an application in EAP or we can run it as a standalone app (Java SE). When running in EAP, the connection pooling is again provided through the DataSource. When running standalone, we provide another connection pooling - through C3P0 library. JDG is then configured with PooledConnectionFactory.
Comment 6 Martin Gencur 2013-09-27 02:41:10 EDT
One correction, the C3P0 library and PooledConnectionFactory were not supported in JDG 6.0.1, so we were not providing connection pooling for standalone applications at that point. We started to support it in JDG 6.1.0
Comment 7 gsheldon 2013-10-03 01:01:24 EDT
Based on Martin's comments above, this appears to be not a bug.

"Connection Pooling with JDBC cache store" is marked as available and supported for JDG 6.0.1.

"Connection Pooling with JDBC cache store" was available, however not supported in Library mode for 6.0.1. and is indicated as unsupported in the table. 

Closing as NOTABUG.
Comment 8 gsheldon 2013-10-03 01:01:55 EDT
Please feel free to reopen or comment further is other clarification is required.

Note You need to log in before you can comment on or make changes to this bug.