Bug 1006869 - init script: service restart under the nonroot changed behaviour, it returns 1 instead of 4
init script: service restart under the nonroot changed behaviour, it returns ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 08:26 EDT by Petr Sklenar
Modified: 2016-03-01 09:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Change of permission on confugration file /etc/sysconfig/crond showed a bug in initscript. Consequence: The error message for non priviledged user was different. Fix: Initscript has to check whether configuration file is readable by non root users. Result: Error message looks like before.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:25:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-09-11 08:26:49 EDT
Description of problem:
service restart under the non root changed behaviour, it return 1 instead of 4

Version-Release number of selected component (if applicable):
cronie-1.4.4-11.el6.x86_64

How reproducible:
always

Steps to Reproduce:
rhel64
.qa.[root@x86-64-6s-m1 ~]# su - superman
[superman@x86-64-6s-m1 ~]$ service crond restart
User has insufficient privilege.
[superman@x86-64-6s-m1 ~]$ echo $?
4

rhel65 with cronie-1.4.4-11.el6.x86_64:
[superman@x86-64-6s-m1 ~]$ service crond restart
/etc/init.d/crond: line 37: /etc/sysconfig/crond: Permission denied
[superman@x86-64-6s-m1 ~]$ echo $?
1


Actual results:
error code = 1

Expected results:
error code = 4 

Additional info:
Comment 8 errata-xmlrpc 2013-11-21 17:25:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1681.html

Note You need to log in before you can comment on or make changes to this bug.