Bug 1006896 - emacs-lua package broken
emacs-lua package broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs-lua (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 09:19 EDT by Julian Stecklina
Modified: 2014-01-30 23:30 EST (History)
3 users (show)

See Also:
Fixed In Version: emacs-lua-20130419-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 23:24:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Stecklina 2013-09-11 09:19:15 EDT
Description of problem:

emacs-lua is not compatible with the current emacs version (24.3.1) and plainly does not work.

emacs-lua should ever be updated to anything that is not 6 years old or removed as it is completely useless in its current state.

Version-Release number of selected component (if applicable):
emacs-lua-20071122-11.fc19.noarch

Steps to Reproduce:
1. Open lua file in Emacs
2. Type ()
3. Debugger entered--Lisp error: (void-variable last-command-char)
  lua-electric-match(nil)
  call-interactively(lua-electric-match nil nil)

Actual results:

lua-mode uses last-command-char which was removed from emacs a long time ago.

Expected results:

It doesn't cause an error.

Additional info:

Tracked upstream here: https://github.com/immerrr/lua-mode/issues/57
Comment 1 Fedora Update System 2014-01-20 19:38:44 EST
emacs-lua-20130419-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-lua-20130419-1.fc19
Comment 2 Fedora Update System 2014-01-20 19:39:34 EST
emacs-lua-20130419-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-lua-20130419-1.fc20
Comment 3 Christopher Meng 2014-01-20 20:35:11 EST
Please increase the emacs requires in the spec if possible, and remove old packaging macros as well:

%define --> %global

********************

Remove these:

BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

Whole %clean section

rm -rf $RPM_BUILD_ROOT in %install

%defattr(-,root,root,-)

********************

Change these since RPM has them:

1. %define emacs_lispdir %{_datadir}/emacs/site-lisp

--> RPM macro:

# rpm -E %{_emacs_sitelispdir}
/usr/share/emacs/site-lisp

2. %define emacs_startdir %{_datadir}/emacs/site-lisp/site-start.d

--> RPM macro:

# rpm -E %{_emacs_sitestartdir}
/usr/share/emacs/site-lisp/site-start.d

3. For Emacs version, a macro is also available:

# rpm -E %{_emacs_version}
24.3
Comment 4 Tim Niemueller 2014-01-21 05:15:59 EST
Thanks for the info. I'm building the new packages now and have revoked the old updates. There is also a byte-compile macro that I'm using now. New updates will be posted once built.
Comment 5 Fedora Update System 2014-01-21 05:25:59 EST
emacs-lua-20130419-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-lua-20130419-3.fc19
Comment 6 Fedora Update System 2014-01-21 05:28:14 EST
emacs-lua-20130419-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/emacs-lua-20130419-3.fc20
Comment 7 Fedora Update System 2014-01-21 22:13:50 EST
Package emacs-lua-20130419-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-lua-20130419-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1287/emacs-lua-20130419-3.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-01-30 23:24:31 EST
emacs-lua-20130419-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-30 23:30:48 EST
emacs-lua-20130419-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.