Bug 10069 - can mount a cdrom on hpux and execute but cannot ls
can mount a cdrom on hpux and execute but cannot ls
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-08 12:41 EST by tc
Modified: 2007-04-18 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 14:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tc 2000-03-08 12:41:49 EST
i have here a linux server which exports a iso9660 cd to a hpux 11.0
client. after upgrading to kernel 2.2.12-20 and to knfsd 1.4.7-7 i can
mount the cd, which was not possible before. what is not working, is that i
couldn4t ls on the mounted cd, but because i know the content of the cd
from my linux server, i can execute the files or read. i am not sure if it
is now a knfsd bug or a hpux bug. if i export normal filesystems i even can
read the mounted directories with ls. it seems to be that i am not the
first person who has this problem with hpux, because i found two similar
postings on deja, but they still haven4t solved the bug. i have also a
support contract with hp for my hp machine and opened the same call there.
they tried to trace the problem but haven4t found anything. they rebuild
the situation in their support center and had no problems with ls on the
mounted cd. it would be interesting if you have heard about that. in
bugzilla i haven4t found any report like this one.
Comment 1 Marcel Nijenhof 2000-04-26 16:16:59 EDT
I have seen the same problem on hpux 102.0 and hpux 11 (solaris 2.6 works fine).
I used tcpdump to get some information about the problem and found that the hpux
client system doesn't do a readdir in the case of the cdrom.

A other diference is in the result of getattr call on the mount point. In the
case of the filesystem the blocksize is 4096 for the cdrom it is 0.

There might be a reason in the attributes why the hpux system doesn't try to do
a readdir.

The log for the filesystem:

16:07:15.883479 if04  < 172.16.81.12.810101 > 172.16.1.104.nfs: 104 getattr
[|nfs] (DF)
16:07:15.883671 if04  > 172.16.1.104.nfs > 172.16.81.12.810101: reply ok 96
getattr DIR 41777 ids 0/0 sz 1024
16:07:15.884960 if04  < 172.16.81.12.810102 > 172.16.1.104.nfs: 104 statfs
[|nfs] (DF)
16:07:15.885162 if04  > 172.16.1.104.nfs > 172.16.81.12.810102: reply ok 48
statfs tsize 8192 bsize 1024 blocks 247919 bfree 169434 bavail 156634
16:07:19.742197 if04  < 172.16.81.12.810103 > 172.16.1.104.nfs: 112 readdir
[|nfs] (DF)
16:07:19.742524 if04  > 172.16.1.104.nfs > 172.16.81.12.810103: reply ok 668
readdir offset 1 size 24001 eof
16:07:19.745010 if04  < 172.16.81.12.810104 > 172.16.1.104.nfs: 116 lookup
[|nfs] (DF)
16:07:19.745417 if04  > 172.16.1.104.nfs > 172.16.81.12.810104: reply ok 128
lookup fh Unknown/1
16:07:19.746798 if04  < 172.16.81.12.810105 > 172.16.1.104.nfs: 120 lookup
[|nfs] (DF)

And the log for the cdrom:

15:56:08.041870 if04  < 172.16.81.12.810097 > 172.16.1.104.nfs: 104 getattr
[|nfs] (DF)
15:56:08.042022 if04  > 172.16.1.104.nfs > 172.16.81.12.810097: reply ok 96
getattr DIR 40555 ids 0/0 sz 2048
15:56:08.043342 if04  < 172.16.81.12.810098 > 172.16.1.104.nfs: 104 statfs
[|nfs] (DF)
15:56:08.043484 if04  > 172.16.1.104.nfs > 172.16.81.12.810098: reply ok 48
statfs tsize 8192 bsize 2048 blocks 328493 bfree 0 bavail 0
Comment 2 Cristian Gafton 2000-08-08 22:34:45 EDT
assigned to johnsonm
Comment 3 Stephen John Smoogen 2003-01-25 00:20:02 EST
This bug looks similar to other export issues with 7.0/7.1 and their nfs items.
I think that most of them were taken care of with 7.3/8.0. Can you duplicate it
still?
Comment 4 Jay Turner 2003-04-14 14:39:58 EDT
Closing out due to bit-rot.

Note You need to log in before you can comment on or make changes to this bug.